RAPIDMINER 9.7 BETA ANNOUNCEMENT

The beta program for the RapidMiner 9.7 release is now available. Lots of amazing new improvements including true version control!

CLICK HERE TO DOWNLOAD

The code below is what I'm receiving when I try to connect to database to launch the RapidMiner ser

figsfigs Member Posts: 16 Learner I
edited March 27 in Help
at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
        at java.awt.EventDispatchThread.run(Unknown Source)
Caused by: java.net.ConnectException: Connection refused: connect
        at java.net.DualStackPlainSocketImpl.waitForConnect(Native Method)
        at java.net.DualStackPlainSocketImpl.socketConnect(Unknown Source)
        at java.net.AbstractPlainSocketImpl.doConnect(Unknown Source)
        at java.net.AbstractPlainSocketImpl.connectToAddress(Unknown Source)
        at java.net.AbstractPlainSocketImpl.connect(Unknown Source)
        at java.net.PlainSocketImpl.connect(Unknown Source)
        at java.net.SocksSocketImpl.connect(Unknown Source)
        at java.net.Socket.connect(Unknown Source)
        at org.postgresql.core.PGStream.<init>(PGStream.java:75)
        at org.postgresql.core.v3.ConnectionFactoryImpl.tryConnect(ConnectionFactoryImpl.java:91)
        at org.postgresql.core.v3.ConnectionFactoryImpl.openConnectionImpl(ConnectionFactoryImpl.java:192)
        ... 46 more
Tagged:

Best Answer

Answers

  • MarcoBarradasMarcoBarradas RapidMiner Certified Analyst, Member Posts: 121   Unicorn
    hi  @figs it says your connection was refused please check all of the following
    • Type of Database and port
    • User has permissions on the DB you are going to use
    • Password confirm the password you entered
    • If the DB is on another server check if both server can see each other through you network
    I see you are using postgresql as DB maybe @rfuentealba or @BalazsBarany could help us if you paste more details on the error.

  • BalazsBaranyBalazsBarany Administrator, Moderator, Employee, RapidMiner Certified Analyst, RapidMiner Certified Expert Posts: 441   Unicorn
    Hi,

    thanks @MarcoBarradas. The "Connection refused" error is before any authentication. The database simply doesn't listen on the address you're connecting to.

    PostgreSQL is usually configured to listen on localhost (127.0.0.1) by default. This means that you can't reach it from an external computer. This is a security measure for installations where the application runs on the database server itself (e. g. a web server). 
    If you want the database to listen on public addresses, you need to change the listen_addresses setting in postgresql.conf and restart the database server.

    Regards,
    Balázs
  • figsfigs Member Posts: 16 Learner I
    Thanks guys. Im not use to Java. How do I change the address settings in postsql?
  • BalazsBaranyBalazsBarany Administrator, Moderator, Employee, RapidMiner Certified Analyst, RapidMiner Certified Expert Posts: 441   Unicorn
    Hi @figs,

    RapidMiner is written in Java, so you are using it.

    I described exactly how to change the listening address in the PostgreSQL configuration. If this is too terse for you, check the PostgreSQL documentation, it's really verbose and well written.

    Regards,
    Balázs
    MarcoBarradas
  • figsfigs Member Posts: 16 Learner I

  • figsfigs Member Posts: 16 Learner I
    This is what I'm getting when I try to download rapidMiner server...what does JAVA PATH: Null
  • MarcoBarradasMarcoBarradas RapidMiner Certified Analyst, Member Posts: 121   Unicorn
    Hi @figs if you are under Windows you need to create a enviroment variable call Java Path that will point to the place in which your java bin files are.
     Here you can find how to do it on different OS https://explainjava.com/java-path/
    figs
  • figsfigs Member Posts: 16 Learner I
    Does Null mean it couldnt find the java file?
  • figsfigs Member Posts: 16 Learner I
    Im also using windows 10
  • figsfigs Member Posts: 16 Learner I
    I downloaded the latest jre version 8 from Oracle. It detected old versions of Java and removed them
Sign In or Register to comment.