RapidMiner

Learner I ali_alyasiry198
Learner I

Connecting Amazon EMR with Radoop

Hi 

I need help please has any one connected Radoop with Amazon EMR. I am trying to do that using rapidminer studio &radoop 7.3. I have followed the distribution notes for EMR and I have done all the steps but I got the following error:

 

Dec 5, 2016 11:26:06 AM] SEVERE: Test failed: Hive connection

[Dec 5, 2016 11:26:06 AM]: Cleaning after test: Hive connection

[Dec 5, 2016 11:26:06 AM]: Total time: 0.436s

[Dec 5, 2016 11:26:06 AM] SEVERE: java.sql.SQLException: Could not open client transport with JDBC Uri: jdbc:hive2://localhost:1235/default: null

[Dec 5, 2016 11:26:06 AM] SEVERE: Hive server 2 connection test failed. Please check that the server/daemon runs and is accessible on the address and port you specified.

[Dec 5, 2016 11:26:06 AM] SEVERE: Test failed: Hive connection

[Dec 5, 2016 11:26:06 AM] SEVERE: Connection test for 'test' failed.

 

 screen 1.png

5 REPLIES
RM Staff
RM Staff

Re: Connecting Amazon EMR with Radoop

Hi,

 

the configuration looks like ok, but I assume, that you skipped the networking setup and a SOCKS proxy is not initialized. There is a "Setup networking" paragraph with a link to a SOCKS Proxy setup. Please check your SSH connection and SOCKS setup.

 

Zoltán

 

Learner I ali_alyasiry198
Learner I

Re: Connecting Amazon EMR with Radoop

Thanks for reply

I have already done the SOCKS Proxy setup but I have the same problem.

 

RM Staff
RM Staff
Solution

Re: Connecting Amazon EMR with Radoop

Hi,

 

the error message indicates, that the client is not able to initiate a TCP connection to the Hive port. 

 

Please check, that:

- you initiated the SOCKS connection to the master node

- Hive is running on that node, e-g- listens on the port 10000

- You did the port forwarding from localhost:10000 to the master node:10000 (-L 10000:localhost:10000 in the SSH settings)

 

Zoltán

RM Staff
RM Staff

Re: Connecting Amazon EMR with Radoop

Sorry, I mean:

 

- You did the port forwarding from localhost:1235 to the master node:10000 (-L 1235:localhost:10000 in the SSH settings)

Learner I ali_alyasiry198
Learner I

Re: Connecting Amazon EMR with Radoop

Hi

yes I did that just like the document using putty " 

  • Create a SOCKS proxy on port 1234.
  • Set up an SSH tunnel from the local port (1235) to the Hive Server node port (10000)." So what do you recommend me?
Polls
How can RapidMiner increase participation in our new competitions?
Twitter Feed