RapidMiner

[SOLVED] Set Role error in RA (but works in RM)

Wisdom logo Registration now open for RapidMiner Wisdom Americas | New Orleans | October 10-12, 2018   Learn More
ppsheehy
Not applicable

[SOLVED] Set Role error in RA (but works in RM)

Hi,

I have a simple flow in RM that reads in data from a repository and then sets the role for one variable - 'operation' to be label. It works fine in RM 5.3.015, but when I execute it on RapidAnalytics (1.2) I get an error at the 'Set Role' operator. In the console it appears like this: com.rapidminer.operator.UserError: The attribute '' does not exist.

It only appears to affect the Set Role operator (this flow is stripped down from a larger flow that worked OK apart from Set Role). It affects all attributes, not just the one in the flow.

I checked the XML and the 'Set Role' operator does appear to be correct (i.e. the attribute name is included)

<?xml version="1.0" encoding="UTF-8" standalone="no"?>
<process version="5.3.015">
 <context>
   <input/>
   <output/>
   <macros/>
 </context>
 <operator activated="true" class="process" compatibility="5.3.015" expanded="true" name="Process">
   <process expanded="true">
     <operator activated="true" class="retrieve" compatibility="5.3.015" expanded="true" height="60" name="Retrieve SmallDataset" width="90" x="45" y="120">
       <parameter key="repository_entry" value="SmallDataset"/>
     </operator>
     <operator activated="true" class="set_role" compatibility="5.3.015" expanded="true" height="76" name="Set Role" width="90" x="179" y="165">
       <parameter key="attribute_name" value="operator"/>
       <parameter key="target_role" value="label"/>
       <list key="set_additional_roles"/>
     </operator>
     <connect from_op="Retrieve SmallDataset" from_port="output" to_op="Set Role" to_port="example set input"/>
     <connect from_op="Set Role" from_port="example set output" to_port="result 1"/>
     <portSpacing port="source_input 1" spacing="0"/>
     <portSpacing port="sink_result 1" spacing="0"/>
     <portSpacing port="sink_result 2" spacing="0"/>
   </process>
 </operator>
</process>

Any thoughts?

Thanks,

ppsheehy
2 REPLIES
RM Staff RM Staff
RM Staff

Re: Set Role error in RA (but works in RM)

Hi,

please always keep Studio and Server on the same minor version (e.g. Studio 6.1 requires Server 2.1). Otherwise you might get weird behavior or broken stuff.
In your case the parameter for the attribute got renamed between minor version 2 and 3, so running a 5.3 process on a 1.2 server will result in the server looking for a different parameter than your process contains. If you update RA to 1.3.15, it will work as expected.

Regards,
Marco
_________________________________________________________
Team Lead Software Engineering | RapidMiner GmbH
ppsheehy
Not applicable

Re: [SOLVED] Set Role error in RA (but works in RM)

Thank you for the prompt reply. that solved the problem.

I should have realised something was up when I saw that RM 5.2 was launched by RA instead of 5.3...

Again, many thanks,

ppsheehy