RapidMiner

RapidMiner

E-mail support for Rapid Miner 7

SOLVED
Highlighted
Regular Contributor

E-mail support for Rapid Miner 7

[ Edited ]
Spoiler
 

Hello

I am trying to enable e-mail support on my recent RapidServer installation, however I am getting timeout exception and I hope some one can help me..

 

I have followed the steps from this article and my standalone.xml looks like

 <subsystem xmlns="urn:jboss:domain:mail:1.2">
            <mail-session name="java:/Mail" jndi-name="java:/Mail" from="username@intelexus.com.br">
                <smtp-server outbound-socket-binding-ref="mail-smtp">
                    <login name="username@intelexus.com.br" password="pa$$word"/>
                </smtp-server>
            </mail-session>
        </subsystem>
        <outbound-socket-binding name="mail-smtp">
            <remote-destination host="mail.intelexus.com.br" port="25"/>
        </outbound-socket-binding>

And this is the log:

21:30:56,150 WARNING [de.rapidanalytics.tools.JndiMailSessionFactory] (http-/0.0.0.0:8888-1) Property com.rapidanalytics.mail.jndi_name is undefined. Assuming 'java:/Mail'.
21:32:11,887 SEVERE [com.rapidminer] (http-/0.0.0.0:8888-1) Cannot send mail to xxxxxx@gmail.com: javax.mail.MessagingException: Could not connect to SMTP host: mail.intelexus.com.br, port: 25;
  nested exception is:
	java.net.ConnectException: Operation timed out

 

I am quite sure that my server has this unsecure version to connect with 

> username@intelexus.com.br

> smtp: mail.intelexus.com.br

> port: 25

 

There is also another option with (more secure) with SSL/TLS

> smtp: br704.hostgator.com.br

> port: 465

 

I also tried to ping my domain, use the IP instead the domain...

 

Can somebody give some tip to solve this issue? Or provide some config to use a gmail account.

 

Thanks!

1 REPLY
Moderator

Re: E-mail support for Rapid Miner 7

Hi,

 

the following works for me using Gmail. Please shut down your RapidMiner Server 7.2 before doing this:

 

  1. Find the "mail:1.2" subsystem
  2. Change the "from" value to "your.name@gmail.com"
  3. Replace the entire contents of the <smtp-server> tag with the following:
  4.  <smtp-server outbound-socket-binding-ref="mail-smtp" ssl="true">
         <login name="your.name@gmail.com" password="yourPassword"/>
    </smtp-server>
  5. (stupid forum, this should be number 4): Look for the <outbound-socket-binding name="mail-smtp"> at the bottom of the standalone.xml file and change the <remote-destination> tag to:
    <remote-destination host="smtp.gmail.com" port="465"/>
  6. Start RM Server again

You should now be able to send emails via the "System Settings" -> "Email configuration" web page.

 

Regards,

Marco

_________________________________________________________
Team Lead Software Engineering | RapidMiner GmbH