Can't start RapidMiner 5 using Windows mandatory roaming profiles

userboy87userboy87 Member Posts: 1 Contributor I
edited November 2018 in Help
We use mandatory roaming profiles for students in our undergraduate labs. That means each student logs in with a copy of a profile created for  a "template" user. Unfortunately, when a student user attempts to use the program, RapidMiner hangs at the "Loading GUI Properties" stage, with a flock of exceptions complaining about not being able to create the .RapidMiner5 directory in the "template" user's profile directory in C:\user. Of course, the "template" user's profile doesn't exist on the machine when it's in regular use (since the "template" user's profile is of necessity a roaming profile and disappears from the machine as it is supposed to), and in any case, its profile directory wouldn't be writable for a student user. I can't find where Rapid Miner gets this erroneous path information on startup, but can it be overridden? The problem only occurs for users of the mandatory roaming profile. All other users are able to start RapidMiner without a problem.

Answers

  • landland RapidMiner Certified Analyst, RapidMiner Certified Expert, Member Posts: 2,531 Unicorn
    Hi,
    actually RapidMiner retrieves the user directory delivered from the operating system. We thought this would be a place where you will always have write access, but obviously we didn't think of such a setup you are using.
    Of course RapidMiner should be able to start anyway and just forget every setting after exiting, and we might change this in future. Please add this as a feature request to our bug tracker.
    This is one of the situations, where it would be handy being academic enterprise customer. You would have a release solving that problem before the end of the week.

    Greetings,
      Sebastian
  • Ghostrider11Ghostrider11 Member Posts: 1 Contributor I
    Hi

    We are now having this issue since we upgraded to Windows 7, never had the problem under Windows XP. Students use mandatory roaming profiles and the program freezes on the "Loading GUI Properties" splash screen stage. It works no problem for users without the roaming profiles but this is not an option for us.

    Has anybody come across a fix for this?
  • Marco_BoeckMarco_Boeck Administrator, Moderator, Employee, Member, University Professor Posts: 1,992 RM Engineering
    Hi,

    you can try and start the RapidMinerGUI.bat (located in the scripts folder of the RapidMiner installation) from the command line. There you can see what's wrong and hopefully fix it - at least that's the way the original poster sorted out his problem.

    Regards,
    Marco
Sign In or Register to comment.