πŸ₯³ RAPIDMINER 9.9 IS OUT!!! πŸ₯³

The updates in 9.9 power advanced use cases and offer productivity enhancements for users who prefer to code.

CLICK HERE TO DOWNLOAD

missing ordered type and can not discretize my label

Legacy UserLegacy User Member Posts: 0 Newbie
edited November 2018 in Help
Hi,

i've got 3 problems. The first one is that i miss the attribute "ordered". In version 4.1 I've read timestamps from database and they attribute type was ordered. With version 4.2 the values are nominal. I tried to convert them with the nominal2date operator, but i have already missing values in this column. This operator throws an Error because they can not handle it. When there is no solution for this problem, I want to transform the timestamps in unix timestamps (integer).

The second problem I've got is that my label is numeric and i like to discretize them. But I have no Idea how? All descretize-operator don't handle special attributes.


Problem 3: Many, such as the BinDiscretization, affect all numeric columns, but why? I only want to operate on a specific column. How can I realise it?

Regards,
David

Answers

  • TobiasMalbrechtTobiasMalbrecht Moderator, Employee, Member Posts: 291  RM Product Management
    Hi,

    ok, here we go:

    1. As far as I remember, the attribute type ordered was not used by any operator, that is no operator used the ordering information. Hence it was removed. Concerning the [tt]Nominal2Date[/tt] operator, we also already discovered the fact, that it was not able to handle missing values. We fixed this issue in the newest CVS version of RapidMiner. There is also a new operator [tt]Date2Numerical[/tt] which is able to convert a date attribute back to a timestamp (and other time measures). This operator is also part of the newest CVS version, but it is however not heavily tested yet and may be "experimental"...Β  ;)

    2. Simply change the label to type regular by applying the operator [tt]ChangeAttributeRole[/tt] before the discretization and transform it back by the same operator afterwards.

    3. Use the discretization operator as an inner operator of the operator [tt]AttributeSubsetPreprocessing[/tt]. As parameter you have to chose an [tt]attribute_value_filter[/tt] and specify the name of the attribute you want to discretize.

    Hope that solves your problems,
    Tobias

  • Legacy UserLegacy User Member Posts: 0 Newbie
    Thanks, that's was what I'm looking for.
Sign In or Register to comment.