"Process Documents from Files with csv dataset"

luca_manluca_man Member Posts: 2 Contributor I
edited May 2019 in Help
I'm trying to experience the 'Process Documents from Files' component and I've been trying to load a bunch of csv files, instead of html like maybe it's supposed to work.
It works ok except from the fact that I'm using the ',' as a separator and rapidminer by default uses ';', so I don't see the proper column.
How can I change this option in order to have my bunch of csv files loaded properly?



  • Options
    SebastianLohSebastianLoh Member Posts: 99 Contributor II
    hi luca.man,

    for loading csv files in RM usually the Read CSV operator is the right choice. There you can set also the column seperator and there is also a wirzard that supports you to setup the Read CSV operator.

    The Process Documents operator class is usually only used in order to conduct text mining tasks, like analysing news, twitter .... . So if you have a table in csv format, use the Read CSV operator.

    Ciao Sebastian
  • Options
    luca_manluca_man Member Posts: 2 Contributor I
    Yeah, in fact I saw that with the semicolon it didn't change the behaviour. I found it interesting because I have a big instance set of csv file.
    I'll do a work around.

Sign In or Register to comment.