πŸ₯³ RAPIDMINER 9.9 IS OUT!!! πŸ₯³

The updates in 9.9 power advanced use cases and offer productivity enhancements for users who prefer to code.

CLICK HERE TO DOWNLOAD

LibSVM problem

UsernameUsername Member Posts: 39  Guru
edited November 2018 in Help
Hi,

I used the GridSearchParameterOptimization operator and the ProcessLog operator to find the best C value. The result was C=75 (accuracy: 76%). If I try to setup a process without GridSearchParameterOptimization and with the C value of the LibSVM learner set to 75 (via GUI or ParameterSet) I get an accuracy of only 73%. I can repeat these processes as often as I want, the accurays are always the same. The accuracys of C=75 is always higher if the GridSearchParameterOptimization operator was used. How can this be possible?

Thanks

Answers

  • TobiasMalbrechtTobiasMalbrecht Moderator, Employee, Member Posts: 291  RM Product Management
    Hi,

    I assume you used a cross validation inside the parameter optimization. The difference in accuracies probably occurs, because the example set partitions in both cross validations differ which happens when you use the global random generator for both cross validations. You can force the cross validation to sample identically by using the same local random generator. This can be done by setting the parameter [tt]local_random_seed[/tt] of the [tt]XValidation[/tt] operator to an identical positive value (e.g. 100).

    Hope this was helpful,
    Tobias
  • UsernameUsername Member Posts: 39  Guru
    Hi,

    thanks for the fast answer. I will try if it solves my problem.
  • UsernameUsername Member Posts: 39  Guru
    Hi,

    that was the reason of the different results.Β  :)
Sign In or Register to comment.