"Execute R Script --

dragoljubdragoljub Member Posts: 241 Contributor II
edited May 2019 in Help
I am trying to run some basic Kernel Density Estimation (KDE) using RpaidMiner's Execute R Script operator.

Unfortunately neither the kde() nor density() functions work in the execute script operator. They give the following error:

"In getDependencies(pkgs, dependencies, available, lib) : package 'mlr' is not available"

Strangely, in the R perspective everything works as expected. What is the execute R script operator doing to cause this error. I don't even try to import the mlr package in my code.  ???

This is the site to the mlr package: http://mlr.r-forge.r-project.org/

Their install command
does not work.

UPDATE: Ok I solved this problem. It turns out the MLR site is very badly organized for my eyes. I finally found the download link for the MRL library. https://r-forge.r-project.org/bin/windows/contrib/latest/mlr_0.3.1206.zip

Extract the zip and place the mlr folder into your ../R/library/ directory.

I also placed the mlr folder in C:\Users\username\.RapidMiner5\rLibPath  just in case.  ;D

This still begs the question, why is RM calling MLR without being packaged with it?  :D



  • Options
    landland RapidMiner Certified Analyst, RapidMiner Certified Expert, Member Posts: 2,531 Unicorn
    Hi Gagi,
    actually it should download MLR automatically. We use MLR to get a common interface to the classification and regression methods of R. I have to check why the download fails.

  • Options
    nandadoreanandadorea Member Posts: 14 Contributor II
    I am having the very exact problem - the code works on the R perspective, but now when I run the process, and I get the same message. But now the link posted by dragoljub does not work either.... any ideas? does anyone know where to find the package mlr?


    I googled the package name from Gagi's message and found this website:
Sign In or Register to comment.