"RM 5.1.1.does not read Excel files"

MuehliManMuehliMan Member Posts: 85 Maven
edited May 2019 in Help
Dear all,

I updated RM to version 5.1.1. and suddenly my processes did not work anymore. The first error occured with the Read EXCEL operator, where A0 as cell range was not accepted. I guess A1 is working, but I did not check it thoroughly. Secondly the attributes where not read on the fly and thus the Rename operator caused numerous warnings.

Did anyone else encounter this behaivior? MEanwhile I downgraded to version 5.1.0.

Cheers,
Markus
Tagged:

Answers

  • landland RapidMiner Certified Analyst, RapidMiner Certified Expert, Member Posts: 2,531 Unicorn
    Hi,
    the cell Range A0 of course does not work: Excel starts counting on 1. The question is: Did you enter this or was there an error in the automatic translation of a pre 5.1 process?

    Greetings,
    Sebastian
  • MuehliManMuehliMan Member Posts: 85 Maven
    Hey Sebastian,

    I think you already guessed it right. It was the value assigned by importing an "old" RM 5.0 workflow. So maybe the value A0 was set as the default value, if it has not been set before?

    Do you have any comments on the fact, that the attributes' name was not preloaded and available for other Operators (e.g. Set Role). <It is not causing the process to fail, but the number of warnings is a bit distracting.

    Cheers,
    Markus
  • landland RapidMiner Certified Analyst, RapidMiner Certified Expert, Member Posts: 2,531 Unicorn
    Hi,
    I have fixed the issue with the counting, this should work with the next version.

    The MetaData are not loaded any longer if you don't set them using the wizard. It simply takes to long to always parse the complete excel file during the meta data propagation. That's why we have introduced the repository in the first place, please use it instead to always have fast and proper meta data.

    Greetings,
    Sebastian
Sign In or Register to comment.