"Yet another R Extension problem"

bluecatbluecat Member Posts: 2 Contributor I
edited May 2019 in Help
      I've been diligently going through the previous posts and trying to tweak my settings to make R Extension work but I still get the common issue "Can't find dependent libraries" for jri.dll

I am running Windows 7 64 bit, with R 64 not and Rapidminer 64 bit

I downloaded the rJava package and I am using the jri.dll from the \x64 directory

Here are my environmental variables:
JAVA_HOME = C:\Program Files\Java\jdk1.6.0_24\jre
Path = C:\Program Files\R\R-2.12.1\bin\x64; C:\Program Files\Java\jdk1.6.0_24\jre\bin
R_HOME = C:\Program Files\R\R-2.12.1

Have people got R Extension to work under 64-bit? Thank you for all of your help


  • Options
    B_B_ Member Posts: 70 Maven
    I'm also having problems setting up R on a Win 7 x64 system.

    I successfully set up R 2.11 and RM  on an XP 32 bit system last year.  I used my notes and the RM R extension setup instructions for R 2.12 x 64.

    RJava is installed in the R library in the user subdirectory with a x64 jri.dll.  I've set JAVA_HOME, R_HOME and added the java jre, R x64 bin and RJava x64  jri.dll folders to my path and restarted.

    RM starts to boot then fails and the boot screen disappears.  When I remove the R extension section from extensions.xml RM will startup with no problems.
  • Options
    B_B_ Member Posts: 70 Maven

    With the help from Sebastian's example and other comments from this thread
    I've been able to get R running on Win 7 x64.

    c:\program files\java\jre6\bin

    C:\Program Files\R\R-2.12.2

    add to path (make sure there is a semicolon after the original path text before adding the new text)
    ;C:\Users\workstation\Documents\R\win-library\2.12\rJava\jri\x64;c:\program files\r\r-2.12.2\bin\x64;c:\program files\java\jre6\bin

    r.native lib is pointed to the x64 jri.dll in the R library

    Good luck

  • Options
    bluecatbluecat Member Posts: 2 Contributor I
    Sorry for the tardy response but those directions worked perfectly thank you very much!!!
  • Options
    nandadoreanandadorea Member Posts: 14 Contributor II
    I tried all these instructions and I still cannot get the R extension to work

    I am running Windows 7 x64, and these are my settings:

    C:\Program Files\Java\jre6\bin  (I also tried without the \bin, as suggested in another post)

    ; C:\Program Files\R\R-2.12.2\library\rJava\jri\x64; C:\Program Files\R\R-2.12.2\bin\x64; C:\Program Files\Java\jre6\bin

    C:\Program Files\R\R-2.12.2


    r.native lib:
    C:\Program Files\R\R-2.12.2\library\rJava\jri\x64\jri.dll

    When I frist tried the extension, RapidMiner would not open at all, just keep restarting itself. Now at least it doesn't do that, but the Extension screen still comes up everytime I open RapidMiner, until I finally just disable the extension. Can anyone see what I am still doing wrong?

    Thank you already for any help.

  • Options
    keithkeith Member Posts: 157 Maven

    FWIW, in both of the x64 systems I have RM+R configured on (one XP, one Win7), the PATH variable does not contain the location of JRI.DLL  (C:\Program Files\R\R-2.12.2\library\rJava\jri\x64 in your config), but does have the paths to the R x64 executable and the Java executable.  Since you're specifying the direct path to JRI.DLL in the rapidminer.r.native.lib setting within RM, it's possible that "seeing" the DLL in two different places (PATH and RM setting) might be confusing the system?

    Also, I don't know if the PATH variable you included was the entire path, or just the part that seemed relevant to R/RM.  If the latter, I would also check that your path does not accidentally contain the directories for 32-bit versions of R, Java, or jri.dll

    Hope this helps,
  • Options
    nandadoreanandadorea Member Posts: 14 Contributor II
    Thanks for the attention Keith. I did try deleting from Path the address to the .dll file as suggested, but it didn't solve it. I also checked that theer are not extra addresses in PATH (except for something unrelated, Miktek). I also tried pointing to the jre folder on RM, rather than java, and stil... nothing....
  • Options
    nandadoreanandadorea Member Posts: 14 Contributor II
    KEITH, thanks!
    now I did solve it thanks to your comment. the address to MiKtek that was in my path, though unrelated to RM, was to a x32 foler of Miktek, so deleting it from my path solved it!! thank you so much, I will have to deal with Miktek later, but now I have teh Rextension in rapidMiner at last. Thank you!!
  • Options
    earmijoearmijo Member Posts: 270 Unicorn
    I followed B.'s instructions and now I have R working together with RApidminer. My two favorite applications. Thanks a lot.

    (I have Windows 7. R 2.11.)
Sign In or Register to comment.