image

🎉 🎉 RAPIDMINER 9.10 IS OUT!!! 🎉🎉

Download the latest version helping analytics teams accelerate time-to-value for streaming and IIOT use cases.

CLICK HERE TO DOWNLOAD

"R extension installation problem"

AjAj Member Posts: 23  Maven
edited May 2019 in Help
Hello ,

I have Fedora 14 installed on my system.

I have downloaded the zip file for rapidminer and extracted it to my home directory, i.e I did not do any compilation or installation

I then when in to lib directory of rapidminer and clicked on rapidminer.jar . Rapidminer opened up and then I updated all different extensions, including R.

I then erased R using
yum erase R
After that,  I installed R using "yum install R"
version is 2.12.2

As the instructions mention, I typed
install.packages("rJava")
inside R and it got "rJava" package installed in
/usr/lib/R/library

Inside R, when I type .libPaths(), I get
[1] "/usr/lib/R/library"  "/usr/share/R/library"

In PATH, I included
/usr/lib/R/lib:/usr/lib/R/bin
Here /usr/lib/R/lib contains libR.so .

R_HOME is set to
/usr/lib/R

JAVA_HOME is set to /etc/alternatives/java_sdk .

After clicking on "Next" button of "R Extension Installation Instructions" page, I pointed it to the directory
/usr/lib/R/library/rJava/jri

It is taking REngine.jar, even though the instructions say libjri.so is what it will be looking for.
I also get the message found library in
/usr/lib/R/library/rJava/jri/REngine.jar
(I later tried pointing to JRIEngine.jar and libjri.so, but same result)

The installation instruction mention the following
"If the new R Perspective has been added after restart, everything runs just fine. If not this dialog will show up again, please check if the file is in the correct directory, is accessible by RapidMiner"

Therefore, something is wrong as the window again shows up.

I have restarted the console so that environment variables are reset, verified them that they are all set correctly. Also, I unpacked rapidminer to a new different directory, after all the above are set. I also rebooted the computer (windows way). But, none of them worked.

I also tried removing R using yum erase and then installed R after compiling it. After that, I set the environment variables accordingly. But, the same loop is coming up.
When installing R by compiling from source, rJava version is 2.13.0. While installing using yum , it was either 2.12.0 or 2.12.2

Could anyone please help me out by giving some hints about what might be possibly be wrong and what else I can try to resolve this problem.

Thanks
Ajay

Answers

  • jeszyjeszy Member Posts: 13 Contributor II
    Hello,

    I use the R Extension on Fedora 14 and it works fine for me. A self-made
    installation guide that covers both Fedora and Windows is available
    at

      http://www.inf.unideb.hu/~jeszy/download/datamine/doc/rapidminer.pdf

    Unfortunately, it is written in Hungarian, but you can give it a try. (The
    shell commands are self-explanatory.)

    Best regards,

    Peter
  • AjAj Member Posts: 23  Maven
    Hi Peter,

    Thanks for replying and help. Unfortunately, I do not understand Hungarian. But, I have figured out the solution.

    I started rapidminer using command prompt, instead of doubling click on jar file. I went through the output closely and noticed that  it is unable to find the dynamic library to load REngine.

    As mentioned in the instruction window to get R extension working with Rapidminer, lib.so is that dynamic linking library. Therefore, I searched for that library linking problems in R itself. I found the following URL that mentions about the problem.

    http://rpy.sourceforge.net/rpy_faq.html

    I first tried creating symlink, which is the first option mentioned. But, it did not work. I later a command equivalent to
    export LD_LIBRARY_PATH=$LD_LIBRARY_PATH\
              :R_HOME/bin

    in .bashrc , it worked.

    Therefore, it looks like it is more of a R problem than rapid miner problem.

    Thanks,
    Ajay
Sign In or Register to comment.