image

🎉 🎉 RAPIDMINER 9.10 IS OUT!!! 🎉🎉

Download the latest version helping analytics teams accelerate time-to-value for streaming and IIOT use cases.

CLICK HERE TO DOWNLOAD

Using SQLServer driver

gemifygemify Member Posts: 2 Contributor I
edited November 2018 in Help
Does anyone have experience setting up a SQLServer JDBC driver in RM 5.1?

Here's what I've already done:
-installed SQLServer JDBC drivers
-installed new driver in RM (Tools->Manage Database Drivers)
-setup a DB connection (Tools->Manage Database Connections)

I'm running SQLServer Express. My connection details looks like this:
Database system : SQLServer (my driver that I'd previously installed)
Host: localhost/sqlexpress
Port: 1433
Database schema:
User: <username>
Password: <password>
URL shows up on the UI as : jdbc:sqlserver://localhost/sqlexpress:1433

When I hit the 'Test' button, I get the following (partial) message:
The TCP/IP connection to the host localhost/sqlexpress, port 1433 has failed. Error: "null. Verify t...

The rest of the message is not visible in the UI. SQLServer browser service is up. TCP is enabled.

Any help is appreciated! Thanks!

Answers

  • keithkeith Member Posts: 157  Guru
    I have JDBC to SQL Server working successfully in RM 5.1.  Looking at what you're doing, the three things I notice as different are (1) I have a backslash instead of a forward slash in the host-instance and (2) I happen to be using integrated security to use Windows credentials to connect, and (3) I didn't specify a port number.  My connection URL looks like:

    jdbc:sqlserver://MYSERVER\MYINSTANCE;integratedSecurity=true

    Based on that, and assuming that you aren't using integrated security, I'd suggest trying one of the following two URL's:

    jdbc:sqlserver://localhost\sqlexpress
    jdbc:sqlserver://localhost\sqlexpress:1433

    Hope that helps.

    Keith
  • gemifygemify Member Posts: 2 Contributor I
    That worked beautifully! Thanks a bunch for your help!

    I removed the port and corrected the host to use a backward slash '\' (localhost\sqlexpress). Now the connection works with both integrated as well as sqlserver authentication.
  • TSFTTSFT Member Posts: 4 Contributor I
    Hello, I am facing the same problem you resolve , I can not connect to SQL Server express 2010, the connection dialog fiedls were filled with localhost/SQLEXPRESS with port or without, I have integrated security, I tried to add the string integratedsecurity=true in the field database schema and even so the connection fail, any idea. thanks

    I have tried again to test the connection, now I have a network error ioexception message.
    According to database drivers there is a sql server driver already installed, i am working with 5.3 version of rapidminer, and windows 7, sql server is authenticated qith windows. Any idea.
  • keithkeith Member Posts: 157  Guru
    Try using a backslash instead of a forward slash.  That is, use

    localhost\SQLEXPRESS

    instead of

    localhost/SQLEXPRESS
  • TSFTTSFT Member Posts: 4 Contributor I
    I get a better answer, it seems my system lack a dll that comes with JTDS driver (ntlmauth.dll), a file I can not get at sourceforge.net, the one I need is for windows 7 x64, but I can not access sourceforge.net ,I have tried from Saturday and the site seems to be down and I do not know why. 
  • RWingerterRWingerter Member Posts: 38 Contributor II
    The Sourcefourge download (jtds-1.3.0-dist.zip) comes with a 64 bit version and a 32 bit version of ntmlauth.dll, each in its own subdirectory. Note that the 64 bit DDL in \jtds-1.3.0-dist.zip\x64\SSO must be copied to the C:\Windows\System32[!] directory and the 32 bit DDL in \jtds-1.3.0-dist.zip\x86\SSO must be copied to C:\Windows\SysWOW64[!]. (The names of the Windows system subdirectories are rather confusing, cf. http://en.wikipedia.org/wiki/WoW64). ;

    Hope this helps

    Roland

  • TSFTTSFT Member Posts: 4 Contributor I
    Thank you people,

    I have accessed sourceforeg at last, and I have ntmlauth.dll just in windows/system32 and import database table function WORKED GOOD; the connection stringi have used:

    host: localhost  port:1433
    database: AdventureWorks2008R2;instance=SQLEXPRESS

    Regards.




Sign In or Register to comment.