"Custom extension with dependencies not working"

colocolo Member Posts: 236  Guru
edited May 23 in Help
Hello everybody,

since there still is no "problems" board in this section, I first tried posting my problem in the RapidMiner board, where a similar problem was solved before. But since this question is already open for some weeks, I will try to post the description in a (hopefully) proper place (original post):


Previous operators from my own extension are working fine on the server. The new one is the first that depends on other plugins, and the dependencies seem to be defined different on the server (although the dependency between web and text extension seems to work fine). I just copied the relevant JARs (Web Mining, Text Processing, own extension) from my RapidMiner_Vega\lib\plugins to the server's plugin directory. When trying to execute a process containing the new "GetPage" derivate I receive a message complaining about a similar problem to the one from my first post:
Process cannot be created: com.rapidminer.tools.XMLException: Cannot create operator: Operator cannot be constructed: 'get_page_advanced(com.rapidminer.matthias.webmining.retrieval.GetWebpageAdvancedOperator)': com/rapidminer/operator/text/Document.
I tried using the Webstart version where I cannot even drag the operator into my process area. The other operators (from my extension) are working fine.

I would be glad if the solution was as simple as it was in the RapidMiner context :)

Best regards
Matthias
Tagged:
Sign In or Register to comment.