🎉 🎉 RAPIDMINER 9.10 IS OUT!!! 🎉🎉

Download the latest version helping analytics teams accelerate time-to-value for streaming and IIOT use cases.

CLICK HERE TO DOWNLOAD

"Problems in importing a .csv file to Rapid Miner"

kushanibanukushanibanu Member Posts: 3 Contributor I
edited May 2019 in Help
Hi All,

I am using Rapid Miner 5.0.010 version in a data mining project (A churn prediction system uding decision tree approach).

When I  create a data set by importing a .csv file the data set gets created successfully, but some attribute values in some records are displayed as missing values. (Question marks are displayed in value field). But these values are not actually missing in .csv file.

That is data in .csv file and data set are incompatible.

Data Set contains about 26 fields and 20000 records. Values are always missing in same 6 fields (Only in some records).

Does anyone have a solution for the problem?

Thanks
Tagged:

Answers

  • SkirzynskiSkirzynski Member Posts: 164  Maven
    Hey,

    i would guess that the reader can not parse these values. If you post a snippet from your data with one column and two rows where in one row the data is correctly read and in the another not, than i can have a look.

    Marcin
  • kushanibanukushanibanu Member Posts: 3 Contributor I
    Hi,

    Thank you for the reply. It seems a data formatting issue and got solved the problem. When opened the .csv file in Excel, made all the fields General and then again imported the file to RapidMiner, it worked well.

    Thanks again.

    Kushani
  • HelloLolaHelloLola Member Posts: 18 Contributor I

    Hello I have a problem when importing .csv file:

     

    Failed to parse the content in column "INF"

    Cause: Unparseable number: "cousin"

     

    can you help me please

     

    Thank you

  • Thomas_OttThomas_Ott RapidMiner Certified Analyst, RapidMiner Certified Expert, Member Posts: 1,760   Unicorn

    The data type is set to numerical and it's expecting either a real or integer. Since you have cousin in it, it's throwing an error. Set the data type to Polynominal in the import wizard and it should work. 

Sign In or Register to comment.