After Several Runs I am Running Out of Memory

yakitoyakito Member Posts: 22 Maven
edited November 2018 in Help

I have a process which applies a model to a wordlist and writes the prediction into a DB. The process is running on a cron job once every hour.
The first few times it runs fine, but after the 4, or 5 it runs out of memory.

I tried using the "Free Memory" Operator but I dont see the memory going down after the process runs. There is really no reason to keep the memory as all the necessary data is being sent to the DB.

How can I free all the memory after I run the process, is there something I can do? Maybe I am misusing the "Free Memory" operator?

Right now these are my last 2 operators:
      <connect from_op="Write Database" from_port="through" to_op="Free Memory" to_port="through 1"/>
      <connect from_op="Free Memory" from_port="through 1" to_port="result 1"/>

Any help will be much appreciated.


  • MariusHelfMariusHelf RapidMiner Certified Expert, Member Posts: 1,869 Unicorn

    how exactly do you start your process? Are you using RapidMiner or RapidAnalytics?

  • yakitoyakito Member Posts: 22 Maven
    Hi! Sorry for the delay, I am using RapidAnalytics to run the process once every hour.

    What I also noticed is that if I run the process using RapidMiner several times I also get the memory error. For some reason it looks like memory is not set free after the process is completed.

    Any hint?

  • MariusHelfMariusHelf RapidMiner Certified Expert, Member Posts: 1,869 Unicorn
    Which version are you using? We fixed a memleak with version 5.2.1. If an upgrade does not fix your issues, it would be helpful to post your process setup, so that we can see which operators are causing the problems. Please try to generate a minimal process for which the problem occurs.

Sign In or Register to comment.