[SOLVED] Can't launch .rmp file from command line using RapidMinerGUI

minerchrisminerchris Member Posts: 5 Contributor II
edited November 2018 in Help
This is frustrating. After everything I've managed to migrate all my extensions from RM4.6 to RM5.2, only to bump into an issue with the way RapidMinerGUI handles .rmp file now.

Previously with RM 4.6 you could simply launch (I'm using Ubuntu/Linux) ./scripts/RapidMinerGUI /path/to/test.xml

With RM 5.2 and the newer .rmp file format (and some kind of matching .properties file) when I try to launch with my own .rmp or one created by RM 5.2 GUI itself, I get the Exception:

Exception: com.rapidminer.repository.RepositoryException
Message: Requested repository null does not exist.
Stack trace:
 com.rapidminer.repository.RepositoryManager.getRepository(RepositoryManager.java:189)
 com.rapidminer.repository.RepositoryLocation.getRepository(RepositoryLocation.java:144)
 com.rapidminer.repository.RepositoryLocation.locateEntry(RepositoryLocation.java:167)
 com.rapidminer.gui.actions.OpenAction.open(OpenAction.java:136)
 com.rapidminer.gui.RapidMinerGUI.run(RapidMinerGUI.java:262)
 com.rapidminer.gui.RapidMinerGUI.launch(RapidMinerGUI.java:499)
 com.rapidminer.gui.RapidMinerGUI.main(RapidMinerGUI.java:482)

Want a simply way to reproduce it?

1) Open RapidMinerGUI.
2) Start the 1st Tutorial example.
3) Save Save as...
4) Close RapidMinerGUI.
5) From a shell in the installation directory: ./scripts/RapidMinerGUI <path to your saved .rmp>
6) Enjoy the exception.

When saving a .rmp file, RM5.2 will include a .properties file (undocumented from what I can tell). Its largely an empty properties file, but this is a <comment> with "Properties of repository entry test" included in it. I have no idea if this is a clue as to how RM 5.2 works with project files anymore.

Finally! I can't explain why, but RM 5.2's Open project dialog is creating .property files of directories and files that you navigate but don't select! This is inexplicable and really poor behavior.

If you launch RapidMinerGUI as normal, select Open -> NewLocalRepository, click around. Select a couple of directories, select some files. Then take a look at your file system. Every directory or file you selected has a matching .properties file!?!?! Now my working directories have a bunch of .properties files I have to clean up every time I open a .rmp in RM 5.2? I probably never would have seen this if I was able to launch my .rmp from the command line...

I haven't had a good experience with RM 5.2. I won't bother going into what's missing from the Extensions Guide (which I paid for) seeing as I managed to port over my old Extensions.

Please fix this.

Answers

  • minerchrisminerchris Member Posts: 5 Contributor II
    SOLVED AND UPDATED! And why isn't this documented....!?!?

    From the command line you need to specify the repository (type I supposed) such as DB or "NewLocalRepository" in the form of:

      //<repo type/path/to/repo

    I have no clue how a DB is captured like this, (remote versus local, etc...) but for local .rmp file it would look like this:

      //NewLocalRepository/Project/rm_project

    Do not include the .rmp extension. Just the .rmp filename. Exclude your user's home path from the .rmp file path.

    How did I clue into this? The Open/Save dialogs built up the "Location" with the repo type included in the path. The MOST annoying thing I can't seem to over come is that NewLocalRepository's are from the root of the user's home directory. You have to create a symlink under $HOME if you want to point to a repo that's not actually located under your $HOME directory.

    Some simple RapidMinerGUI command line usage (you know, --help) could have solved all of this. I had to dig into the RM source to start piecing this together.

    Not impressed. There is no reason why RapidMinerGUI couldn't simply support pointing directly to a .rmp file without the //. Rapid-i purposely changed this behaviour and it's not clear. Even the naming of "NewLocalRepository" doesn't work. It should be "LocalRepository" since it's not new, it's an existing one, in both the Open and Save dialogs.

    I'm still seeing garbage .property files all over the place when you navigate directories in the Open dialog. At least now I don't have to use the dialog. I can just launch my .rmp files from the command line directly.
  • MariusHelfMariusHelf RapidMiner Certified Expert, Member Posts: 1,869 Unicorn
    Please don't double-post, and open your threads in the correct subforum.
Sign In or Register to comment.