[SOLVED] Where are the Scatter Plots and Other Plots?

jcurry1jcurry1 Member Posts: 24 Contributor II
edited November 2018 in Help
I was reading an online tutorial that went through all of the different plots available.  But I can't see any.  I just need the scatter plot.  But I don't see it in the list of operators.  How do I do a scatter plot on data that I have just imported from Excel for example?


  • MariusHelfMariusHelf RapidMiner Certified Expert, Member Posts: 1,869 Unicorn
    Hi, if you have to connect the output of the Read Excel operator to the process output on the far right of the process view. Then run the process and open the Result View. There you can select different views of the data with the radio button on the top of the program. Using "Plot View" or "Advanced Charts" you can plot your data.

    Did you check out the video tutorials on http://rapid-i.com ? You can also find the documentation for the advanced charts in the download area on our website.

    Best, Marius
  • jcurry1jcurry1 Member Posts: 24 Contributor II
    Yeah, I saw the tutorial.  The weird thing is that when I try to  switch to Results View I don't see the there is  no Result Overview with Plot View and Table View underneath.  It just says Process at the top. So it seems to just maximise the process window.

    I've tried everything including going back to Default Perspectives but I can't seem to get the proper Results View window up. Any ideas? I'm on 5.1?  Unfortunately I can't reinstall easily on that pc as it is offline.

  • MariusHelfMariusHelf RapidMiner Certified Expert, Member Posts: 1,869 Unicorn
    The update to RapidMiner 5.2 is out since some weeks, but that should not be related to your problem.

    Please post your process setup, so we can check that you connected everything correctly. Please have a look at this post to get instructions on how to do that: http://rapid-i.com/rapidforum/index.php/topic,4782.0.html

    Best, Marius
  • jcurry1jcurry1 Member Posts: 24 Contributor II
    Thanks Marius, I will post the xml tonight.
  • jcurry1jcurry1 Member Posts: 24 Contributor II
    Hi ,
    I just post the simplest example below.  I import from Excel and run the import.  Then I click on Results View and it just maximises the Process window.

    <?xml version="1.0" encoding="UTF-8" standalone="no"?>
    <process version="5.1.017">
      <operator activated="true" class="process" compatibility="5.1.017" expanded="true" name="Process">
        <process expanded="true" height="529" width="806">
          <operator activated="true" class="read_excel" compatibility="5.1.017" expanded="true" height="60" name="Read Excel" width="90" x="55" y="121">
            <parameter key="excel_file" value="C:\Users\Arm&amp;John\Desktop\SMURF\DM\Course Materials\Practical 3\Borrower.xls"/>
            <list key="annotations"/>
            <list key="data_set_meta_data_information"/>
          <connect from_op="Read Excel" from_port="output" to_port="result 1"/>
          <portSpacing port="source_input 1" spacing="0"/>
          <portSpacing port="sink_result 1" spacing="0"/>
          <portSpacing port="sink_result 2" spacing="0"/>
  • jcurry1jcurry1 Member Posts: 24 Contributor II
    I've also tried updating to RapidMiner 5.2.  Same problem...
  • jcurry1jcurry1 Member Posts: 24 Contributor II
    Its fixed now.  I reinstalled RapidMiner 5.2 (running as administrator).  That still didn't do it.  It was when I hit "Restore Default Perspective" that it started working. 

    Thats weird because I had hit that a number of times. Perhaps I had clicked that while in the process view only and had to click it while in the Results view to restore that particular perspective.  Not sure. I'll just  put it down to silly error while  getting used to new software.

    Thanks Marius.

Sign In or Register to comment.