[SOLVED] Upload a Model to a RA Repository without copy/paste from RapidMiner?

yakitoyakito Member Posts: 22 Contributor II
edited November 2018 in Help

I have the following flow:

I run processes on my local server and then upload the process and the model to an EC2 instance which runs the process on a local RapidAnalytics server on a cron basis.

The problem I am seeing lately is that when I copy the model from my local server into the EC2 server it often fails. I am assuming it is because of the file size, although the model is not big at all, just around 25MB.

Is there any other way, like FTP or something I can use to upload RapidMiner files into a RapidAnalytics server?

Thanks so much in advance,


  • Options
    fischerfischer Member Posts: 439 Maven

    you can make an HTTP POST or PUT to /RAWS/resources/PATH

    and set the Content-Type header to "application/vnd.rapidminer.ioo". But that does the same as RapidMiner does. Does your database allow blobs of that size? In mysql you must increase the maximum packet size as well because that is 1MB by default.

  • Options
    yakitoyakito Member Posts: 22 Contributor II
    This was an issue with the EC2 instance, when I switched to the medium instance it worked. Thanks!
Sign In or Register to comment.