The Altair Community is migrating to a new platform to provide a better experience for you. The RapidMiner Community will merge with the Altair Community at the same time. In preparation for the migration, both communities are on read-only mode from July 15th - July 24th, 2024. Technical support via cases will continue to work as is. For any urgent requests from Students/Faculty members, please submit the form linked here.
Options

[Solved] getNominalMapping Fail

JagsusJagsus Member Posts: 13 Contributor II
edited November 2018 in Help
Hi,
i am trying to run real attributes through a Decision Tree (W-LMT from the WEKA Addons) and of course I have put a Discretize operator in front of it.
But when I start the process I get this:

Process failed
The method getNominalMapping() is not supported by numerical attributes! You probably tried to execute an operator on a numerical data which is only able to handle nominal values. You could use one if the discretization operators before this application.

And that message sort of confused me because that was exactly what I did.
At first, just to test if the operator would work, I just took my dataset, made one attribute label, ran it through the Discretize operator und after that through the W-LMT. That worked fine.
But now I'm not adressing the label directly in the Discretize, but by macro (see attatched xml code); the rest is exactly the same as in my test process (so I allready thought this is the problem, but I can't see why).

You can find the operator in Loop Attributes > Work on subset > the last X-Validation.
All the other X-Vals worked fine (process has run several times without the W-LMT and without problems)

Hope you can help!

Ps.: Dropbox link leads to a text data conatining the xml. Couldn't attach it here
http://dl.dropbox.com/u/6522515/IPH/xml.txt

Answers

  • Options
    awchisholmawchisholm RapidMiner Certified Expert, Member Posts: 458 Unicorn
    Hello

    Sometimes using the materialize data operator can magically sort this sort of problem out. Put one before the first Multiply within the Work On Subset operator (don't ask me to explain why - I might not be able to).

    If that doesn't work, you could move the discretize outside the X validation - it could be that the boundaries are slightly different when used inside this operator thereby causing the names to be different leading to confusion

    Best of luck!

    regards

    Andrew
  • Options
    JagsusJagsus Member Posts: 13 Contributor II
    Moving the Discretize in front of the validation worked good.

    The only sad thing is, that i can't find a performance operator like that for all the other vals (Performance(Regression)).

    But thanks a lot :)
Sign In or Register to comment.