[SOLVED] Not able to launch RapidMiner from Eclipse

lakshmilakshmi Member Posts: 6 Contributor II
edited November 2018 in Help
Hello everybody,

I am working on my Master thesis on Artificial Neural Networks. I have developed a process in RapidMiner.
I have integrated Python in Eclipse and I have a Python script which runs the RapidMiner process several times.
However I am not able to launch RapidMiner from Eclipse and get the expected results.

This is the error message i have got:

Exception in thread "main" java.lang.NoClassDefFoundError: com/rapid_i/Launcher
at com.rapidminer.tools.ParameterService.ensureRapidMinerHomeSet(ParameterService.java:489)
at com.rapidminer.RapidMinerCommandLine.run(RapidMinerCommandLine.java:113)
at com.rapidminer.RapidMinerCommandLine.main(RapidMinerCommandLine.java:170)
Caused by: java.lang.ClassNotFoundException: com.rapid_i.Launcher
at java.net.URLClassLoader$1.run(Unknown Source)
at java.security.AccessController.doPrivileged(Native Method)
at java.net.URLClassLoader.findClass(Unknown Source)
at java.lang.ClassLoader.loadClass(Unknown Source)
at sun.misc.Launcher$AppClassLoader.loadClass(Unknown Source)
at java.lang.ClassLoader.loadClass(Unknown Source)
... 3 more

I am new to both the tools, i really cannot understand what this says. Can anyone help me with this?
I would be grateful.
Thanks in advance.

Lakshmi  :)


  • Options
    Marco_BoeckMarco_Boeck Administrator, Moderator, Employee, Member, University Professor Posts: 1,996 RM Engineering

    you're missing required libraries, in this particular case the launcher.jar lib. Make sure to add all required libraries to your project (if in doubt, just add all of them).

  • Options
    lakshmilakshmi Member Posts: 6 Contributor II
    Yeah it worked.. thnx u very much for the great support for this tool.
Sign In or Register to comment.