"Slow and crash Rapidminer"

andrasandras Member Posts: 2 Contributor I
edited June 13 in Help
Hello

I use free Rapidminer, but too slow when I do simple task.

I have in my pc 4GB Ram, 2 Cpu, Windows Xp with Service Pack 2.
What can I do for this?
I chaneg my heap memory size 512Mega->4GB but it didn't help to me.

Thank you!

Andras
Tagged:

Answers

  • Nils_WoehlerNils_Woehler Member Posts: 463  Guru
    Hi,

    well what simple task are you trying to do? And What do you mean by slow? Does the GUI not respond? Or does your task take a long time to finish?

    Best,
    Nils
  • andrasandras Member Posts: 2 Contributor I
    Hi,

    When I do simple decision tree from example video.

    GUI always freeze when I build on workflow. and don't reaspond.
    I don't reach the end of task because froze before.

    Thank you!

    Andras
  • fritmorefritmore Member Posts: 90  Maven
    hi
    I have been also experiencing slowing down of RM (the calculation gets slower and slower with a new run, the gui gets sluggish too).
    Eventually RM pops a message not enough memory......  and thats that. I have to close it and it starts all over again.

    Running 64 bit java. Newest RM. (was happening in the prev version too).

    ??? ??? ???
  • haddockhaddock Member Posts: 849  Guru
    Hi Guys,

    Bear in mind that results take up space, so it is memory efficient to clear them after a run. Also check out Marius' answer at http://rapid-i.com/rapidforum/index.php/topic,4195.msg16784.html#msg16784 .

    Best

    H
  • fritmorefritmore Member Posts: 90  Maven
    Hi cptn

    i've got it set up so that the result view is cleared before every new run; the gradual slow down just keeps on progressing anyway.
    It is regardless of the sys resources state or any other java apps (or any apps ) running or not.

    I read the thread you linked, no solution there either. At least I dropped a note there for the RM dev boys and girls.

    well..lets hit the exit and restart RM once again ..and again and again and again,,,,, (if it at least started in under 2secs....)

    f
  • haddockhaddock Member Posts: 849  Guru
    Hi,

    Why not post your process, so we can all see the deceleration?

    Best

    H

  • Nils_WoehlerNils_Woehler Member Posts: 463  Guru
    Hi,

    posting your process is a good idea so we can have a look at it to check what operator consumes
    your memory without freeing it.

    Best,
    Nils
  • fritmorefritmore Member Posts: 90  Maven
    ehm  ::) sorry

    it seems it was my fault. I was testing a model on a hold out data set but did not change the list (in select attributes )of the attributes specific to the model...

    I do not understand that it let me to apply an incomplete attribute set to the model (producing pretty lousy and weird results, the slow down and the eventual not enough memory message).

    f


  • gogolgogol Member Posts: 4 Contributor I
    Hi Guys,

    What a hack is going on with Rapid-I;

    I've a brand new high tech Samsung Laptop with a brand new Win7 x64 opreation system.
    Installed the latest Rapid-I (5.2.008) with some extensions ( Paralell, R ).

    The javaw.exe CPU usage is 25 percent even if I am doing nothing. Nothing, I mean nothing just look at the Rapid-I gui screen.
    If I move the mouse pointer the CPU usage increase to 50%, the CPU cooler fun turn to 20000RPM ( ok, that's another issue )

    Doing anything, tring even the most minimal task the CPU usage is almost 90! percent

    Just to make clear what's the problem, using all office, 3d, internet, browser, etc. program and applications together use
    less CPU than Rapid-I alone.

    Is there a way to play arround with the configuration? ( as I've seen by the previous version had some )
    Could You write me a sort article, description about how to optimeze, or deal with this Issue?

    Thank any of You in advance.
    And last but not least, Thank you for developing and share wiht us this great software.

  • MariusHelfMariusHelf RapidMiner Certified Expert, Member Posts: 1,869   Unicorn
    Hi Gogol,

    which version of RapidMiner did you install? 32bit or 64 bit? The 32 bit version sometimes has some problems on 64 bit windows. Namely it may detect only 256 MB of RAM, which in turn will keep the garbage collection and thus the cpu constantly busy.
    Try to have a look at RapidMiner's system monitor. You can activate it by using the View menu -> Perspectives -> System Monitor. It will show you how much RAM RapidMiner can use.

    If unsure about which version you downloaded, you can also have a look if it is installed into C:\Program Files\Rapid-I (64bit) or C:\Program Files (x86)\Rapid-I.

    If you have already installed the 64bit version or installing it does not help, please let us know.

    Best regards,
    Marius
  • gogolgogol Member Posts: 4 Contributor I

    Hi Marius,

    I use 64 bit version, it is in C:\Program FIles\Rapid-I\Rapid Minder 5.2.0008 folder. System monitor window show 1.8 GB max, and 181 MB total respectively.

    Bulit-in windows process explorer show that javaw.exe use 310 MB ram.

    The most strange thing is that the javaw.exe CPU use starts 25 percent right after the start rise up to 50 percent, and if I doing something on the GUI (for example,
    move a box from a bit, or connect one to the other, or just change the view from one tab (repositories) to another (operators) CPU is jump up to
    98-100 percent.

    Thise things occure when I try to do something on the GUI as I described before, not when run a process;

    Thanks for your help,
  • MariusHelfMariusHelf RapidMiner Certified Expert, Member Posts: 1,869   Unicorn
    Hm, actually it is a bit strange and obviously something is wrong there. I can't give you definitive instruction, but here are some things you can try:
    - install the latest version of Sun Java
    - delete the .RapidMiner5 directory in your users home directory (this will also remove all extension)

    Does one of these help?

    Best regards,
    Marius
  • gogolgogol Member Posts: 4 Contributor I

    Hi Marius,


    Still doesn't understand what is Java and what it does, but I download the latest
    Java SE Runtime Environment 7 update 11 for 64-bit platform from this page

    http://www.java.com/en/download/manual.jsp

    ## http://sdlc-esd.sun.com/ESD6/JSCDL/jdk/7u11-b21/jre-7u11-windows-x64.exe

    Now I know that 3 billinon devices run Java :7


    That didn't help me a lot, but as I've seen this gone into the C:\Program Files\Java\jre7 directory

    When the RapidMiner is running, the Windows Task Managger showed jawav.exe file path
    is C:\Program Files\Rapid-I\RapidMiner52\jre\bin


    Give a last chance the problem to be solved, remove the prevoiously isntalled java, than installed
    again but now into the RapidMiner directory (of corse after everything was removed from RapidMiner\jre directory).


    Well, there wasn't any improvement.

    The javacpl.exe shows that the platform is 1.6, the product is 1.7.0_11, the location is http://java.sun.com/products/autodl/j2se
    the path is C:\Program Files\Rapid-I\RapidMiner52\jre\bin\javaw.exe and it is enabled;
    Runtime Parameters field are empty;


    Looked around the Windows system environment setting found that there is a JAVA_HOME varible with
    C:\Users\iDroid\Documents\R\win-library\2.15\rJava\jri\x64 value;

    Temporary removed this entry from the settings and disabeled every plugin in Rapid-I;

    The performance wasn't better at all ( as I mentioned before the default javaw.exe
    CPU is 25 percent, increase up 98~99 percent when a Rapid-I process is running )

    I found that the RapidMiner.exe occures in Windows Task Managger as
    RapidMiner.exe *32 (which I think is refer to 32-bit version, while the path shows
    C:\Program Files\Rapid-I\ directory which is definetly belongs to 64-bit)

    Maybe this description will be help to solve the problem.

    I really appreciate your help.

  • gogolgogol Member Posts: 4 Contributor I

    Hi Markus,


    RapidMiner 5.0.010 32-bit and 5.0.010 64-bit downloaded from sourceforge and installed on my laptop, both of them
    work properly; CPU usage never rise above 50 percent, after a process is made coming
    back to 0~1 percent (so it works properly);
    64-bit version use 570~750 megabyte memory right after starting, but that is ok, there
    is a lot more free;

    just to satisfy my curiosity, removed the well working version (5.0.010 64-bit)
    of RapidMiner, and installed version 5.1.016 64-bit ( the latest 5.1 version );

    the same problem occurred with 5.2.008 64-bit (meanwhile the 32-bit version
    of 5.2.008 was tested but that also didn't work well)

    However, I would like to draw your attention to this; there should be something between 5.0.xxx and 5.1.xxx

    Thank you for your help, and keep up the good work,
    Gogol

  • aborgaborg Member Posts: 67 Contributor II
    Hi,

      I have experienced similar slowdowns on Windows 7 Home Edition (64 bit with 32 bit RM, updated from 5.1 to 5.2) sometimes. My suspect is the usage statistics collector/sender. I have a similar setup, but there it is not enabled, and no problems with it (although it is not English, and the RM 5.2.008 is the first installed version, so not identical). Currently I cannot reproduce this behaviour on the first system, so I cannot give further details (like what are the two threads that are running when 2 of 4 cores are fully used by the RM process). I guess this was not memory related, as it seems the UI is responsive, but during GC I think that would freeze the UI too.
    Thanks, gabor

    PS.: The guess about the usage stats is just a blind guess, might be wrong.
  • ploroploro Member Posts: 2 Contributor I
    Hi all from a newbie,

    I have exactly the same symptoms as gogol mentions.

    javaw has 25% CPU use just from start (with saw-apperance on the task manager use history, but uniformly distributed among processors, taking about 25% of each of them), on the first GUI screen, doing *nothing*.
    I have Windows 7 Home edition (64 bits), RapidMiner 5.2 (64 bits) and it runs over javaw 64 bits. I also have a 32-bit have version on the system, but Rapidminer is not using it; RM uses its own Java version (javaw.exe appears as a 64bit application in the task admin).
    I have 8GB RAM and it is a 4-processor CPU with a fresh Windows installation (less than 2 months old and everything going fine and fast).

    After launching RapidMiner, in a question of seconds/minutes, the CPU use for the process javaw.exe reaches 99% (memory usage is constant) and working with RapidMiner is very slow and sluggish. Working with the other applications is still ok.
    When CPU use (on my four processors!) reaches 99% I typically decide to restart RapidMiner and it works fine (25% CPU minimum) for some minutes.
    I'm just using "playtennis" as dataset and not even a model, so it's nothing to do with a heavy process.
    In fact, just opening a process (without running them) and resizing a Window makes javaw reach 50% and stay there forever (with RM minimised).

    I have installed RapidMiner 5.2 on other computers (in fact, hundreds of them in a University) without the problem.

    Thank you!
  • MariusHelfMariusHelf RapidMiner Certified Expert, Member Posts: 1,869   Unicorn
    Hi,
    ploro wrote:
    I have installed RapidMiner 5.2 on other computers (in fact, hundreds of them in a University) without the problem.
    this won't help you, but exactly that is the problem: we have not yet been able to reproduce this problem.
    However, please try to upgrade RapidMiner to the latest version, and come back here if the problem still persists.

    Best regards,
    Marius
  • ploroploro Member Posts: 2 Contributor I
    Thank you Marius for the prompt reply.
    Yes, it looks rather strange...

    I've installed version 5.2 (32 bits) and it's the same thing.
    I even tried version 5.2 (64 bits) with Java 7 (just copying it into the RM directory and renaming the old jre and putting a new one instead). The same result.
    As you suggest, I've just installed version 5.3 (64 bits) and it also starts with 25% CPU use but, for the moment, after doing several things it always comes back to 25% again, and doesn't look slow, so now I can work with RM again :-)
    I must say, though, that the problem appeared with version 5.2 after a few hours of use, so I will see what happens with version 5.3 and will keep you posted.

    P.S. In case this might be helpful, in all the versions I've tried in this computer the "Help" view appears with a sandclock and doesn't connect to the wiki or to the help source. I do have an Internet connection. In fact, RM shows the news information on the startup (welcome) window (perspective). On the other computers where the problem didn't show up, this "Help" window showed the information correctly, so perhaps this is related to the problem because, perhaps, RP (or any Java method) is constantly trying to do something to get the content right to the "Help" window (view). Closing this window doesn't change anything, though.

    (addendum 19/02/2013)
    I've been playing with this version for almost a week, several hours a day. CPU usages has been between 25% and 75% almost all the time, well shared among my four processors (just closing RM makes CPU usage down to about 0% immediately).  could still work quite comfortably with the rest of the CPU  So, it is a strange phenomenon but it doesn't preclude me from enjoying RapidMiner. An excellent project and software!
  • Danyo83Danyo83 Member Posts: 41  Maven
    Hey,

    I have installed the newest version of RM (5.3.005) I have 4 GB available (max) but the total is not even 1 GB. How can I make it to take the maximum RAM?

    Kind regards,
    Daniel

  • Nils_WoehlerNils_Woehler Member Posts: 463  Guru
    Hi,

    did you install the 32-bit or the 64-bit version of RapidMiner?

    Best,
    Nils
  • Danyo83Danyo83 Member Posts: 41  Maven
    64 bit version
Sign In or Register to comment.