"[SOLVED] Memory issue with iMac Lion java 7"

kasper2304kasper2304 Member Posts: 28 Contributor II
edited June 7 in Help
Hi

Knowing that this issue have been addressed before several places, it hurts my pride to bring it up again but I simply cannot solve it, from neither the manual nor searching through google about how to change memory capacity in java.

I am currently using Rapidminer for text mining and i have about 10.000 separate txt. files containing text, i expect to process around 600.000 files as soon as I am done with the preliminary analysis and classification. Needless to say, I need all the computer power available!

To begin with Rapidminer only used 123 mb of ram and I got it using 1 gb simply by updating java. Now I can at least work with 5000 to 10000 pieces of text but it will not be nearly enough.

So my question is: How do I change the java settings to let Rapidminer use at least 8 gb of ram?
As said I have been through the instructions on the site as well as searching for solution on the web.

Please help!?

Kasper

Specs:
iMac 2011 edition
iOS Lion
Processor: intel core 5
Ram: 16 gb
SSD harddisk
Tagged:

Answers

  • kasper2304kasper2304 Member Posts: 28 Contributor II
    Well well...

    Having used Rapidminer today (i installed java 7 yesterday) with the 1 gb max to begin with it seems that the max memory adapts itself. Having run some pretty requiring tasks as fx similarity masurements with misc plots and graphs, the max memory have now gone up to 1.2 gb and earlier it was on 1.1 gb. This leads me to the conclusion that java 7 adapt to the tasks itself.

    Maybe somebody can confirm that?

    Kasper
  • Marco_BoeckMarco_Boeck Team Lead Software Engineering Moderator, Employee, Member, University Professor Posts: 1,806   RM Engineering
    Hi,

    check our homepage on how to increase RAM available to RapidMiner: click.

    Regards,
    Marco
  • kasper2304kasper2304 Member Posts: 28 Contributor II
    Hi  Marco.

    Thanks for your reply.

    I Have been through that page several times and it does not help me. I cant seem to find any of the files/settings it refers to.

    Best
    Kasper
  • Marco_BoeckMarco_Boeck Team Lead Software Engineering Moderator, Employee, Member, University Professor Posts: 1,806   RM Engineering
    Hi,

    I quickly tested way 3, worked like a charm (though I could not test it on a Mac right now). Open the command prompt, switch to the directory you have installed RM to, e.g. X:/RapidMiner/lib, then call "java -Xmx4096m -jar RapidMiner.jar"
    That way the "System Monitor" view in RapidMiner showed 4GB of RAM available right off the bat.

    Regards,
    Marco
  • kasper2304kasper2304 Member Posts: 28 Contributor II
    PROBLEM SOLVED

    I guess I misread the instructions somehow. Somehow i never really figured that it was the terminal/prompt i had to use.

    Thanks a lot Marco. If you want me to I can write a small instruction to how and what I did. Just as a small thx for your help.


    Best
    Kasper
Sign In or Register to comment.