Help Installing RA (JBoss Step)

uriahshonoruriahshonor Member Posts: 4 Contributor I
edited November 2018 in Help
Maybe I am over looking something, or maybe my brain is not fully engaged with the install process, but when I get to section 1.3.1 "Extracting the RapidAnalytics Archive".  when I have extracted my JBoss Bundle....then Where do I put it?

I am on a windows system, and my install directory is c:\rapidanalytics. It would appear that that is where I put the files, but The installer already created those.

I am installing to MS SQL, and got a good connection test in the installer.  Everything appears good, except that I can not open in my browser, and I have not been able to complete this step.

I get teh following errors when executing run.bat

Starting RapidAnalytics Server [2012-11-26 13:50:35]
Calling C:\rapidanalytics\bin\run.conf.bat
===============================================================================

  JBoss Bootstrap Environment

  JBOSS_HOME: C:\\rapidanalytics\\

  JAVA: C:\\Program Files\\Java\\jdk1.7.0_03\bin\java

  JAVA_OPTS: -Dprogram.name=run.bat -Xms128M -Xmx1024M -XX:MaxPermSize=256M -Dsun.rmi.dgc.client.gcInterval=3600000 -Dsun.rmi.dgc.server.gcInterval=3600000 -Dorg.jboss.resolver.warning=true -server

  CLASSPATH: C:\\Program Files\\Java\\jdk1.7.0_03\lib\tools.jar;C:\\rapidanalytics\\\bin\run.jar

===============================================================================

13:50:41,144 INFO  [AbstractJBossASServerBase] Server Configuration:

JBOSS_HOME URL: file:/C:/rapidanalytics/
Bootstrap: $JBOSS_HOME\server/default/conf/bootstrap.xml
Common Base: $JBOSS_HOME\common/
Common Library: $JBOSS_HOME\common/lib/
Server Name: default
Server Base: $JBOSS_HOME\server/
Server Library: $JBOSS_HOME\server/default/lib/
Server Config: $JBOSS_HOME\server/default/conf/
Server Home: $JBOSS_HOME\server/default/
Server Data: $JBOSS_HOME\server/default/data
Server Log: $JBOSS_HOME\server/default/log/
Server Temp: $JBOSS_HOME\server/default/tmp

13:50:41,160 INFO  [AbstractServer] Starting: JBossAS [6.0.0.Final "Neo"]
13:50:47,331 INFO  [ServerInfo] Java version: 1.7.0_03,Oracle Corporation
13:50:47,331 INFO  [ServerInfo] Java Runtime: Java(TM) SE Runtime Environment (build 1.7.0_03-b05)
13:50:47,331 INFO  [ServerInfo] Java VM: Java HotSpot(TM) Server VM 22.1-b02,Oracle Corporation
13:50:47,331 INFO  [ServerInfo] OS-System: Windows XP 5.1,x86
13:50:47,331 INFO  [ServerInfo] VM arguments: -Dprogram.name=run.bat -Xms128M -Xmx1024M -XX:MaxPermSize=256M -Dsun.rmi.dgc.client.gcInterval=3600000 -Dsun.rmi.dgc.server.gcInterval=3600000 -Dorg.jboss.resolver.warning=true -Djava.endorsed.dirs=C:\\rapidanalytics\\\lib\endorsed
13:50:47,394 INFO  [JMXKernel] Legacy JMX core initialized
13:51:07,035 INFO  [AbstractServerConfig] JBoss Web Services - Stack CXF Server 3.4.1.GA
13:51:08,941 ERROR [STDERR] SLF4J: Class path contains multiple SLF4J bindings.

13:51:08,941 ERROR [STDERR] SLF4J: Found binding in [vfs:/C:/rapidanalytics/common/lib/slf4j-jboss-logmanager.jar/org/slf4j/impl/StaticLoggerBinder.class]

13:51:08,941 ERROR [STDERR] SLF4J: Found binding in [vfs:/C:/rapidanalytics/server/default/lib/slf4j-simple-1.6.4.jar/org/slf4j/impl/StaticLoggerBinder.class]

13:51:08,941 ERROR [STDERR] SLF4J: See http://www.slf4j.org/codes.html#multiple_bindings for an explanation.

13:51:09,472 ERROR [STDERR] 516 [JBossWS-CXF-DefaultBus-Init] INFO org.jboss.wsf.stack.cxf.client.configuration.JBossWSBusApplicationContext - Refreshing org.jboss.[email protected]1680781: startup date [Mon Nov 26 13:51:08 CST 2012]; root of context hierarchy

13:51:09,535 INFO  [JSFImplManagementDeployer] Initialized 4 JSF configurations: [Mojarra-2.1.7, Mojarra-1.2, MyFaces-2.0, Mojarra-2.0]
13:51:10,019 ERROR [STDERR] 1063 [JBossWS-CXF-DefaultBus-Init] INFO org.springframework.beans.factory.support.DefaultListableBeanFactory - Pre-instantiating singletons in org.s[email protected]1ebb1ef: defining beans []; root of factory hierarchy

13:51:10,035 ERROR [STDERR] 1079 [JBossWS-CXF-DefaultBus-Init] INFO org.jboss.wsf.stack.cxf.client.configuration.JBossWSBusApplicationContext - Refreshing org.jboss.[email protected]1680781: startup date [Mon Nov 26 13:51:10 CST 2012]; root of context hierarchy
Tagged:

Answers

  • uriahshonoruriahshonor Member Posts: 4 Contributor I
    Here is the server.log file.  I do not understand these missing dependencies.  I thought when I checked the dependencies list before installing RA, that I had all of them.

    DEPLOYMENTS MISSING DEPENDENCIES:
      Deployment "ModClusterListener" is missing the following dependencies:
        Dependency "WebServer" (should be in state "Create", but is actually in state "**ERROR**")
      Deployment "jboss.web.deployment:war=/RA" is missing the following dependencies:
        Dependency "jboss.web:service=WebServer" (should be in state "Create", but is actually in state "** NOT FOUND Depends on 'jboss.web:service=WebServer' **")
      Deployment "jboss.web.deployment:war=/RAWS" is missing the following dependencies:
        Dependency "jboss.web:service=WebServer" (should be in state "Create", but is actually in state "** NOT FOUND Depends on 'jboss.web:service=WebServer' **")
      Deployment "jboss.web.deployment:war=/ROOT" is missing the following dependencies:
        Dependency "jboss.web:service=WebServer" (should be in state "Create", but is actually in state "** NOT FOUND Depends on 'jboss.web:service=WebServer' **")
      Deployment "jboss.web.deployment:war=/invoker" is missing the following dependencies:
        Dependency "jboss.web:service=WebServer" (should be in state "Create", but is actually in state "** NOT FOUND Depends on 'jboss.web:service=WebServer' **")

    DEPLOYMENTS IN ERROR:
      Deployment "vfs:///C:/rapidanalytics/server/default/deploy/rapidanalytics-sqlserver-ds.xml" is in error due to the following reason(s): java.lang.IllegalStateException: jboss.jca:name=jdbc/RapidAnalyticsDS,service=ManagedConnectionFactory is already installed.
      Deployment "WebServer" is in error due to the following reason(s): LifecycleException:  Protocol handler initialization failed: java.net.BindException: Address already in use: JVM_Bind /0.0.0.0:8009, **ERROR**
      Deployment "jboss.web:service=WebServer" is in error due to the following reason(s): ** NOT FOUND Depends on 'jboss.web:service=WebServer' **

    at org.jboss.deployers.plugins.deployers.DeployersImpl.checkComplete(DeployersImpl.java:1228) [:2.2.0.GA]
    at org.jboss.deployers.plugins.main.MainDeployerImpl.checkComplete(MainDeployerImpl.java:905) [:2.2.0.GA]
    at org.jboss.system.server.profileservice.deployers.MainDeployerPlugin.checkComplete(MainDeployerPlugin.java:87) [:6.0.0.Final]
    at org.jboss.profileservice.deployment.ProfileDeployerPluginRegistry.checkAllComplete(ProfileDeployerPluginRegistry.java:107) [:0.2.2]
    at org.jboss.system.server.profileservice.bootstrap.BasicProfileServiceBootstrap.start(BasicProfileServiceBootstrap.java:135) [:6.0.0.Final]
    at org.jboss.system.server.profileservice.bootstrap.BasicProfileServiceBootstrap.start(BasicProfileServiceBootstrap.java:56) [:6.0.0.Final]
    at org.jboss.bootstrap.impl.base.server.AbstractServer.startBootstraps(AbstractServer.java:827) [jboss-bootstrap-impl-base.jar:2.1.0-alpha-5]
    at org.jboss.bootstrap.impl.base.server.AbstractServer$StartServerTask.run(AbstractServer.java:417) [jboss-bootstrap-impl-base.jar:2.1.0-alpha-5]
    at java.lang.Thread.run(Thread.java:662) [:1.6.0_35]

    2012-11-28 16:11:39,640 INFO  [org.jboss.bootstrap.impl.base.server.AbstractServer] (Thread-2) JBossAS [6.0.0.Final "Neo"] Started in 3m:17s:344ms
    2012-11-28 16:19:34,625 INFO  [STDOUT] (Thread-1) Posting Shutdown Request to the server...

    2012-11-28 16:19:34,625 INFO  [org.jboss.bootstrap.impl.base.server.AbstractServer] (Thread-15) Stopping: JBossAS [6.0.0.Final "Neo"]
    2012-11-28 16:24:19,703 ERROR [ProfileServiceBootstrap] (Thread-2) Failed to load profile:: org.jboss.deployers.client.spi.IncompleteDeploymentException: Summary of incomplete deployments (SEE PREVIOUS ERRORS FOR DETAILS):


  • Marco_BoeckMarco_Boeck Team Lead Software Engineering Moderator, Employee, Member, University Professor Posts: 1,806   RM Engineering
    Hi,

    how did you install RapidAnalytics? You mentioned the Installer - it replaces the old method of extracting archives. After using the installer, your RA instance should be good to go right away.

    Regards,
    Marco
  • uriahshonoruriahshonor Member Posts: 4 Contributor I
    I downloaded from here http://rapid-i.com/content/view/289/226/

    I ran the installer after I read through the beginning of the manual.  I began lookinging into the various archive extraction scenarios in the installation section when my install failed.

    In addition to the dependency errors in the server.log file above, I get the following error in boot.log.

    ERROR [STDERR] SLF4J: Class path contains multiple SLF4J bindings.

    I have seen some reference to this on this forum, and a couple of others, but no definitive answers.  I did not have JBoss on this machine prior to installing RA.
  • uriahshonoruriahshonor Member Posts: 4 Contributor I
    I should note that I uninstalled Java 7, and am  now running Java 1.6.0_35
Sign In or Register to comment.