The Altair Community is migrating to a new platform to provide a better experience for you. The RapidMiner Community will merge with the Altair Community at the same time. In preparation for the migration, both communities are on read-only mode from July 15th - July 24th, 2024. Technical support via cases will continue to work as is. For any urgent requests from Students/Faculty members, please submit the form linked here.
Options

[SOLVED] RapidAnalytics Web Service Authentication problem

victor_martinvictor_martin Member Posts: 8 Contributor II
edited November 2018 in Help
Hi There,

I am following Simon's video tutorial "RapidAnalytics 9: File Objects and POSTing to Web Services". I've uploaded my process into RapidAnalytics repository and exposed it as a webservice. Up to here I'm able to run the process through the scheduler and through service Test option.

The problem appears when I try to execute the webservice outside RapidAnalytics web interface. Calling this WS with cURL shows that the server is redirecting to the Login Page:
HTTP/1.1 100 Continue

HTTP/1.1 302 Moved Temporarily
Server: Apache-Coyote/1.1
X-Powered-By: Servlet/3.0; JBossAS-6
Set-Cookie: JSESSIONID=1E386EF633860836EB47164225D9CB88; Path=/RA
Location: http://myserver:8080/RA/faces/login.xhtml;jsessionid=1E386EF633860836EB47164225D9CB88
Content-Length: 0
Date: Mon, 07 Jan 2013 13:30:20 GMT
I have triple checked and certainly I am entering my correct HTTP Basic Auth credentials. I also checked the server logs and found nothing regarding this, so I am stuck here.

Best,
Victor
Tagged:

Answers

  • Options
    victor_martinvictor_martin Member Posts: 8 Contributor II
    My mistake here,

    the URL is  http://host:port/RAWS/processes/serviceID so I was calling a bad endpoint

    Now it works like a charm :)

    Cheers,
    victor
Sign In or Register to comment.