The Altair Community is migrating to a new platform to provide a better experience for you. The RapidMiner Community will merge with the Altair Community at the same time. In preparation for the migration, both communities are on read-only mode from July 15th - July 24th, 2024. Technical support via cases will continue to work as is. For any urgent requests from Students/Faculty members, please submit the form linked here.

"Successful" update without actual update?

aborgaborg Member Posts: 66 Contributor II

I have just seen that there is an update for RM 5.3.000. I use Win7 64 bit, also the 64 bit version of RM. I started the update with non-elevated (regular) user. It finished successfully, restarted, but the version reported is still 5.3.000, not 5.3.5, the update is still to be installed according to the marketplace. I also tried with elevated user, without luck. (The logs do not show any suspicious.) Is it possible, that 5.3.5 is successfully installed, but not shows itself as 5.3.5? How can I check it? Do others have this problem too? (I guess with the installer there would be no problem, so I do not think this is serious problem.)
Thanks, gabor

PS.: It might worth noting, I was not logged in during update (most probably I have no account, maybe this also works there, not tested).


  • Options
    cgkolarcgkolar Member Posts: 29 Maven
    Had the same experience under Win XP 32.  Submitted as bug 1441.
  • Options
    AjAj Member Posts: 23 Contributor II

    I am also experiencing the same problem. My system configuration is as follows

    I have fedora 17 in my system
    for the kernel details, I executed the command,
    "uname -r"
    and I get

    As of now, I have rapidminer 5.2.008 in my system. Also, during the update, I selected all the packages that rapidminer mentioned that I need to update. But, the update process stops after updating one package or so, i.e it does not update all the packages selected. I had to select one package at a time and update the whole list of packages. Even when following this procedure, I could not update to
    ML Wizard 5.2.2
    when my existing version of the package is
    ML Wizard 5.1.1

  • Options
    Nils_WoehlerNils_Woehler Member Posts: 463 Maven
    Hi there,

    hm this seems to be a serious problem.

    @aborg: Do you experience the same problems cgkolar has? Or don't you see the dialog at all? You don't have to be logged in to the marketplace to update installed extensions or RapidMiner. You only have to login to install purchased extensions or to see your bookmark.

    @cgkolar: Because we revised our update mechanism the mentioned RapidMinerUpdate.exe should have come with the update 5.3. We have tested it many times on different machines and it always worked. So now I'm a little surprised that it is missing from your installation. Did you update from 5.2.008 to 5.3 before or did you do a fresh installation of 5.3?

    @Aj: This seems to be a different kind of problem. With RapidMiner 5.3 we have revised our update mechanism. Would you be so kind to update to the latest version 5.3.005 and then try it again?

    Sorry for the inconvenience and thanks for your information. We will try to figure out as soon as possible what is going wrong and how to fix it.

  • Options
    SkirzynskiSkirzynski Member Posts: 164 Maven
    Hi again,

    apparently we haven't tested this enough. Somehow the RapidMinerUpdate.exe got lost during the update from 5.2.8 to 5.3, which causes the error you have mentioned for the next update. We are sorry for any inconvenience this caused. Currently, we are working on this issue.

    In the meantime you can use the following quick fix. Download the missing exe file and copy it into RapidMiner's scripts directory. Start RapidMiner and if you are not prompted for the Administrator password, you have to restart Windows.

    Best regards
  • Options
    SkirzynskiSkirzynski Member Posts: 164 Maven
    The marketplace is fixed, but for an already corrupted installation you have to paste the missing file manually as explained above or in the sticky thread.

    Thanks for reporting!
Sign In or Register to comment.