Write database - Add generated primary keys

miguelalmiguelal Member Posts: 23 Contributor II
edited November 26 in Help
Hi,

Since I upgraded to the latest release of RapidMiner (5.3.005) I seem to keep on getting the error below every time I try to use the option "add generated primary keys" of the Write Database operator. We are connecting to SQL Server 2008 R2, and using the JTDS driver.

Feb 13, 2013 9:20:30 PM SEVERE: Process failed: Database error occurred: A statement attempted to return a result set in executeBatch().

But as soon as we go back to the previous RapidMiner version (5.2), or I disable the "add generated primary keys" option, this problem goes away. This is the XML for the operator:

              <operator activated="true" class="write_database" compatibility="5.3.005" expanded="true" height="60" name="Write Database" width="90" x="45" y="210">
                <parameter key="connection" value="GOGLDB"/>
                <parameter key="table_name" value="BATCH"/>
                <parameter key="overwrite_mode" value="append"/>
                <parameter key="add_generated_primary_keys" value="true"/>
                <parameter key="db_key_attribute_name" value="BATCH_ID"/>
              </operator>
Has anybody come across this issue?

Thanks,
Miguel
Tagged:

Answers

  • Nils_WoehlerNils_Woehler Member Posts: 463  Guru
    Hi Miguel,

    this indeed seem to be a bug. I've filed a internal issue for this.

    Best,
    Nils
  • miguelalmiguelal Member Posts: 23 Contributor II
    Thanks a lot for the prompt response!
  • miguelalmiguelal Member Posts: 23 Contributor II
    Any idea when this issue might get fixed?
    I tried the latest version, and I think it is still happening.
    Is there anything I can do to help?

    Thanks,
    Miguel
  • Nils_WoehlerNils_Woehler Member Posts: 463  Guru
    Hi Miguel,

    the ticket is still open and hasn't been fixed yet. I will leave a message in this thread once this is done.

    Best,
    Nils
Sign In or Register to comment.