The Altair Community is migrating to a new platform to provide a better experience for you. The RapidMiner Community will merge with the Altair Community at the same time. In preparation for the migration, both communities are on read-only mode from July 15th - July 24th, 2024. Technical support via cases will continue to work as is. For any urgent requests from Students/Faculty members, please submit the form linked here.
Options

"[SOLVED]R extension works, but wrong R version"

nandadoreanandadorea Member Posts: 14 Contributor II
edited June 2019 in Help
I am running RapidMiner 5.3, and I got the R extension to work. However, it keeps running in R 2.15.0, even though I have new versions.

I have the following environment variables:

CLASS_PATH: C:\Program Files\Rapid-I\RapidMiner5\jre\bin
JAVA_HOME:C:\Program Files\Rapid-I\RapidMiner5\jre\bin
PATH:C:\Users\me\Documents\R\R-2.15.2\bin\x64;C:\Program Files\Rapid-I\RapidMiner5\jre\bin
R_HOME:C:\Users\me\Documents\R\R-2.15.2
R_LIBS:C:\Users\me\Documents\R\R-2.15.2\library

and the following for rapidminer.r.native lib:
C:\Users\me\Documents\R\R-2.15.2\library\rJava\jri\x64\jri.dll

despite that, when I try to run an R script, it gives me the following:
Failed with error:  'This is R 2.15.0, package 'Rcpp' needs >= 2.15.1'

any suggestions on what I may be doing wrong?
Tagged:

Answers

  • Options
    venkateshvenkatesh Member Posts: 15 Contributor II
    please open a command prompt , type the following commands and post the results

    R --version

    echo %Path%

    echo %PATH%
  • Options
    nandadoreanandadorea Member Posts: 14 Contributor II
    Even without my posting it back I think you solved my problem. My institution does not allow me to have administrator privileges, so I changed my "USER" environment variables, and I thought that would do the trick. When I typed what you suggested on the command prompt, it tells me that the R version is 2.15.0, and I can see that it's fetching the PATH as BOTH my environment variables and the system ones, rather than just the user set PATH.

    I will call our IT support.

    Thanks for the help, and I apologize for taking your time with this issue that is actually on my end....
Sign In or Register to comment.