Problem adding RAM to the JVM using RapidMinerGUI.bat

JayCarrJayCarr Member Posts: 23 Contributor II
edited November 2018 in Help
I've been trying to get RapidMinder to recognize more than 1.5 gb of RAM for the Java Virtual Machine.  I've run into a bit of an odd problem...

I'm using RapidMinerGUI.bat in order to start up RapidMiner (since it has the ability to modify the RAM settings) and it will only allow me to set the RAM at 1500m (anything higher says there is not enough room to start the heap.)  This is odd because my machine has 16gb of RAM...

I decided to try and simply run the .jar from the lib directory instead.  So I used the command java -Xmx4048m -jar RapidMiner.jar .  This did manage to open up Rapid Minder with 4gb of RAM, but it also made it so that my ODBC connections are all broken...  I suppose I could figure out how to instatiate the JDBC drivers from the command line as well, but at that point I might as well create a script and if I'm going to use a script why not just use the one that's already been made, right?

So, I know Rapid Miner can run with 4gb at least, why won't the RapidMinerGUI.bat let me do this?  Is there some flag it is throwing that is stopping the JVM from accepting anything bigger than 1500m?

I'm going to take a look and see if the script is forcing 32-bit (or something).  But I assume that will be slow going as I'm not terribly good at shell scripts.  If anyone happens to know the answer off the top of their head, I would be forever grateful!  ;D


  • Options
    JayCarrJayCarr Member Posts: 23 Contributor II
    The answer to this ended up being somewhat simple, all I needed to do was go and download the 64-bit version of RapidMiner...  ::)

    Sorry for the mix-up.  Sadly, that has introduced a new issue with drivers and such, but I'll post that in another thread.
Sign In or Register to comment.