"Excel Import Problems [SOLVED]"

jeffjeff Member Posts: 6 Contributor II
edited June 2019 in Help
Hi - just installed RM 5.3.7.  When importing Excel files the data previews are all wrong.  The first column of data is repeated across all columns.  I have tried this on several computers with 5.3.7 installed and they all have the same problem.  Any thoughts?
Tagged:

Answers

  • Marco_BoeckMarco_Boeck Administrator, Moderator, Employee, Member, University Professor Posts: 1,993 RM Engineering
    Hi,

    just done a quick test, neither .xls nor .xlsx files show the described behavior for me. Can you upload a minimal example file to reproduce the problem?

    Regards,
    Marco
  • jeffjeff Member Posts: 6 Contributor II
    Hi,

    Thanks for the response.  Sorry it has taken awhile for me to get back to you - traveling.
    The data is the Fisher Iris data.  I have litterally tried this on 6+ different computers and the results are the same.  
    Steps 1, 2, and 3 of the Excel import all look fine.  When I get to step 4, the data from column 1 is repeated in all columns.  That makes choosing the column to be "Label" a little more challenging.  Of course I know that Column E contains the label and has the proper name (Species); however, the data in Column E of the preview shows the column A data (as does Columns B,C,D and E).

    I should say that setting Col E as type Label does work.  That is, the data actually imports correctly even though the display of what is in the columns is incorrect.  It is off putting however.

    The Excel file and a screen capture of step 4 of the import can be seen here:
    https://drive.google.com/folderview?id=0B9Pf2efM6_LkNWNhSXlfWnBOeWM&usp=sharing

    Thanks for any advice/help.
    Best
    JR
  • jeffjeff Member Posts: 6 Contributor II
    Instead of importing an Excel Sheet I saved the sheet as a CSV and imported that.  Step 4 of the CSV import exhibited the same exact behavior as the Excel Sheet import.  That is, in step 4 of the import the Col A data is "previewed" across all columns.  The column Name values are correct and the suggested data types are correct but the preview data is not reflective of the actual column data except for Col A.
  • Marco_BoeckMarco_Boeck Administrator, Moderator, Employee, Member, University Professor Posts: 1,993 RM Engineering
    Hi,

    thank you for the detailed report and test data  :)
    We have verified and fixed the bug in the latest development version.

    Regards,
    Marco
Sign In or Register to comment.