The Altair Community is migrating to a new platform to provide a better experience for you. The RapidMiner Community will merge with the Altair Community at the same time. In preparation for the migration, both communities are on read-only mode from July 15th - July 24th, 2024. Technical support via cases will continue to work as is. For any urgent requests from Students/Faculty members, please submit the form linked here.
Options

[SOLVED] Importing 700+ Columns in RapidMiner

AnalyticaltimAnalyticaltim Member Posts: 15 Contributor II
edited November 2018 in Help
Dear RapidMiner Community,

I have an odd CSV file that I am attempting to use with RapidMiner. This file has 767 columns and only 256 rows. I have been unable to import all the columns into RapidMiner, (it cuts off after 256). Is there an extension or modification that I can use to expand the available size of RapidMiner's columns. The overall data size is not that big yet the amount of columns is quite large and growing.

Thank you very much for your input.

Best,
Tim

Answers

  • Options
    earmijoearmijo Member Posts: 271 Unicorn
    What version do you have installed in your computer? I have no problem whatsoever reading a csv file with 770 columns.
  • Options
    AnalyticaltimAnalyticaltim Member Posts: 15 Contributor II
    I am using the free version 5.3.007.

    Holy cow, I don't know why mine keeps cutting the CSV at 256 rows. Do you think it is an available memory thing?

    Tim
  • Options
    awchisholmawchisholm RapidMiner Certified Expert, Member Posts: 458 Unicorn
    The best thing to do is to post the XML of your process
  • Options
    marcin_blachnikmarcin_blachnik Member Posts: 61 Guru
    Please check if you have choosen correct value separator. It may happen that if you choose incorrect one it may combine several columns into single one, leading to just 256 columns.
    So I suggest to set the separator to ";" or other unique char and configure the same char in the import wizard.
  • Options
    AnalyticaltimAnalyticaltim Member Posts: 15 Contributor II
    Thanks for all your help Rapid-i community.

    I figured it out. Excel was cutting off the sheet at 256 columns. So I put the data into OpenOffice (who does not have that problem) and used the idea of employing a ";" as my separator rather than a comma. It works great and every time.

    Thank you all very much once again.!  ::)

    Best.
    Tim
  • Options
    earmijoearmijo Member Posts: 271 Unicorn
    I should have asked "What version of Excel are you using". From Excel 2007 to the present, Excel can handle up to 16,000 columns. You are probably using Excel 97.
  • Options
    AnalyticaltimAnalyticaltim Member Posts: 15 Contributor II
    You got it. I am using a way old version of Excel. I am thinking that I will switch to OpenOffice on a permanent basis. I love the open source stuff.

    Thanks for all your help!
    Tim
Sign In or Register to comment.