The Altair Community is migrating to a new platform to provide a better experience for you. The RapidMiner Community will merge with the Altair Community at the same time. In preparation for the migration, both communities are on read-only mode from July 15th - July 24th, 2024. Technical support via cases will continue to work as is. For any urgent requests from Students/Faculty members, please submit the form linked here.
Options

[SOLVED] starting-process always freezes at "Legacy JMX core initialized"?

Stefan4UKStefan4UK Member Posts: 3 Contributor I
Hello everybody ,

since my registration in this forum back in November 2012 I tried everything I could to install rapidanalytics on a virtual server in order to test it for my company but the result unfortunately is always that the JBOSS server isn't startable and just freezes within the starting process and even without error message  :(.

First some server-info:
Max-RAM performamce-peak: 4 GB
Always available RAM: 2 GB
OS:Ubuntu 12.04 LTS
Java:
I tried OpenJDK-Java, Oracle Java 1.7 and now Oracle Java 1.6 because I read that this is the recommended version for rapidanalytics.
java version "1.6.0_45"
Java(TM) SE Runtime Environment (build 1.6.0_45-b06)
Java HotSpot(TM) Client VM (build 20.45-b01, mixed mode, sharing)
MySQL-version (Received with the command "SELECT VERSION();" ): 5.5.31-0ubuntu0.12.04.1

The headless installation with the config file as parameter works like a charm and it finishes with the message that rapidanalytics is successfully installed.

Then I try to start the server (in this case even as root to exclude the possibility of permission problems) and unfortunately always end up with this message no matter how long I wait for the starting process to proceed:

root@vservertest:/home/nimda/rapidanalytics# sh bin/run.sh -b 0.0.0.0
=========================================================================

 JBoss Bootstrap Environment

 JBOSS_HOME: /home/nimda/rapidanalytics

 JAVA: /opt/Oracle_Java/jre1.6.0_45/bin/java

 JAVA_OPTS: -server -Xms128m -Xmx1024m -XX:MaxPermSize=256m -Dorg.jboss.resolver.warning=true -Dsun.rmi.dgc.client.gcInterval=3600000 -Dsun.rmi.dgc.server.gcInterval=3600000 -Djava.net.preferIPv4Stack=true -Dprogram.name=run.sh -Djava.library.path=/home/nimda/rapidanalytics/bin/native/lib

 CLASSPATH: /home/nimda/rapidanalytics/bin/run.jar

=========================================================================

08:59:59,506 INFO  [AbstractJBossASServerBase] Server Configuration:

JBOSS_HOME URL: file:/home/nimda/rapidanalytics/
Bootstrap: $JBOSS_HOME/server/default/conf/bootstrap.xml
Common Base: $JBOSS_HOME/common/
Common Library: $JBOSS_HOME/common/lib/
Server Name: default
Server Base: $JBOSS_HOME/server/
Server Library: $JBOSS_HOME/server/default/lib/
Server Config: $JBOSS_HOME/server/default/conf/
Server Home: $JBOSS_HOME/server/default/
Server Data: $JBOSS_HOME/server/default/data
Server Log: $JBOSS_HOME/server/default/log/
Server Temp: $JBOSS_HOME/server/default/tmp/

08:59:59,510 INFO  [AbstractServer] Starting: JBossAS [6.0.0.Final "Neo"]
09:00:04,885 INFO  [ServerInfo] Java version: 1.6.0_45,Sun Microsystems Inc.
09:00:04,885 INFO  [ServerInfo] Java Runtime: Java(TM) SE Runtime Environment (build 1.6.0_45-b06)
09:00:04,885 INFO  [ServerInfo] Java VM: Java HotSpot(TM) Server VM 20.45-b01,Sun Microsystems Inc.
09:00:04,885 INFO  [ServerInfo] OS-System: Linux 2.6.32-042stab055.12,i386
09:00:04,886 INFO  [ServerInfo] VM arguments: -Xms128m -Xmx1024m -XX:MaxPermSize=256m -Dorg.jboss.resolver.warning=true -Dsun.rmi.dgc.client.gcInterval=3600000 -Dsun.rmi.dgc.server.gcInterval=3600000 -Djava.net.preferIPv4Stack=true -Dprogram.name=run.sh -Djava.library.path=/home/nimda/rapidanalytics/bin/native/lib -Djava.endorsed.dirs=/home/nimda/rapidanalytics/lib/endorsed
09:00:05,067 INFO  [JMXKernel] Legacy JMX core initialized
During the starting process this is my memory-usage:

Mem:   4194304k total,   145996k used,  4048308k free,        0k buffers
I absolutely don't know what I always do wrong and desperately hope that there is somebody out there knowing how to deal with this problem. Has anybody of you already heard of a situation like this before?
I intensively searched this forum but unfortunately haven't found anything for my exact situation.
In my opinion the hardware shouldn't be insufficient and there is no error message.

Thanks in advance for your effort
Stefan

Answers

  • Options
    Nils_WoehlerNils_Woehler Member Posts: 463 Maven
    Hi Stefan,

    is this the complete content of your boot.log file? Did you install RapidAnalytics with the installer we provide?

    Best,
    Nils
  • Options
    Stefan4UKStefan4UK Member Posts: 3 Contributor I
    Hi Nils,

    thank you very much for your reply. Yes, that was unfortunately my complete boot.log file and I installed it as described in the rapidanalytics manual.

    In order to get this installation finally done, I upgraded my server hardware to 6 GB RAM and just because of that the rapidanalytics server at least starts successfully  :) but with a lot of error messages. All other configurations stayed the same during the upgrade to 6 GB RAM...

    Is there among all of these enumerous error messages in this boot.log file something I have to worry about?
    Or perhaps is there even a hint for why rapidanalytics wasn't able to start properly with my 2 GB RAM hardware before? 

    http://wp10749649.server-he.de/tmp_logs/boot.txt

    Many thanks for your effort

    Best,
    Stefan
  • Options
    Marco_BoeckMarco_Boeck Administrator, Moderator, Employee, Member, University Professor Posts: 1,996 RM Engineering
    Hi,

    no, the log looks fine. "duplicate class definition bug occured?" can be safely ignored and the many lines saying "ERROR [STDERR] xyz" are actually not errors. A bit strange I do admit, but those quirks will be fixed in a future release ;)

    Regards,
    Marco
  • Options
    Stefan4UKStefan4UK Member Posts: 3 Contributor I
    Hi Marco and Nils,
    thanks a lot your great help....I can't believe it actually works right now :):):)
    Regards,
    Stefan
Sign In or Register to comment.