R error crashes RM

tennenrishintennenrishin Member Posts: 177 Contributor II
edited November 2019 in Help
In R,
results in
Error: '\d' is an unrecognized escape in character string starting "\d"
(because it should have been '\\d')

But in RM
<?xml version="1.0" encoding="UTF-8" standalone="no"?>
<process version="5.3.008">
 <operator activated="true" class="process" compatibility="5.3.008" expanded="true" name="Process">
   <process expanded="true">
     <operator activated="true" class="r:execute_script_r" compatibility="5.3.000" expanded="true" height="60" name="pushChart" width="90" x="313" y="75">
       <parameter key="script" value="grep('\d','1')"/>
       <enumeration key="inputs"/>
       <list key="results"/>
     <portSpacing port="source_input 1" spacing="0"/>
     <portSpacing port="sink_result 1" spacing="0"/>
causes an abrupt termination of RM, without any prompts or messages.


  • Options
    Nils_WoehlerNils_Woehler Member Posts: 463 Maven

    I've had a look into this and it seems like we can't do anything about it The library we are using creates a JRI session to R.
    When providing the command you've posted this session even crashes the Java Runtime Environment:

    # A fatal error has been detected by the Java Runtime Environment:
    #  Internal Error (os_windows_x86.cpp:149), pid=10952, tid=10904
    #  guarantee(result == EXCEPTION_CONTINUE_EXECUTION) failed: Unexpected result from topLevelExceptionFilter
    # JRE version: 7.0_07-b11
    # Java VM: Java HotSpot(TM) 64-Bit Server VM (23.3-b01 mixed mode windows-amd64 compressed oops)
    # Failed to write core dump. Minidumps are not enabled by default on client versions of Windows
    # An error report file with more information is saved as:
    # C:\Users\nwoehler\workspace\RapidMiner\hs_err_pid10952.log
    # If you would like to submit a bug report, please visit:
    # The crash happened outside the Java Virtual Machine in native code.
    # See problematic frame for where to report the bug.
    I'm going to file an issue for this, but probably there is no easy fix for this.

Sign In or Register to comment.