Rapidminer Academia / "Connecting to a RapidMiner Server is not supported "

aruberutouaruberutou Member Posts: 23 Contributor I

I, and the rest of us, appreciate the thoughtful support you put into Rapidminer.

The academia program is especially impressive; however, with the upgrade to v6.5, there seems to have been an oversight; namely: Studio and Server licences are both available, but Studio will not connect to the server.

"Connecting to a RapidMiner Server is not supported by the Academia edition..."

This has got to be an oversight, correct? Server-side execution and repository sharing would seem like a key feature in an edition meant to facilitate teaching and research. I hope this is addressed soon. All our work is stored server-side and cannot be retried with the latest version of RapidMiner as a result.

Answers

  • Marco_BoeckMarco_Boeck Team Lead Software Engineering Moderator, Employee, Member, University Professor Posts: 1,750   RM Engineering
    Hi,

    the Academia Studio version should be able to connect to the Academia Server version. If it does not, it's a bug. We are investigating this.

    Regards,
    Marco
  • Marco_BoeckMarco_Boeck Team Lead Software Engineering Moderator, Employee, Member, University Professor Posts: 1,750   RM Engineering
    Hi,

    I can confirm that this is a bug :-[
    We are working on a fix for that. I will post here once it is ready. It may take a little while because we need to change the already issued licenses themselves.

    Regards,
    Marco
  • Marco_BoeckMarco_Boeck Team Lead Software Engineering Moderator, Employee, Member, University Professor Posts: 1,750   RM Engineering
    Hi,

    good news! The issue should be fixed :)
    You can either go "Help" -> "Manage Licenses..." -> "Download Licenses" and then restart Studio or you can just restart Studio twice.
    In any case, the actual license key has changed, so if you have stored it somewhere, you need to update it. The web interface will display the new key.

    Regards,
    Marco
  • aruberutouaruberutou Member Posts: 23 Contributor I
    Hi, Marco,

    Thanks for the BLAZING fast response.

    I tried your solution, but it still doesnt seem to work. I even went as far as reapplying the license from the website. The error, however, continues to pop-up. I did not have the foresight to compare the key in the web interface to the one already installed; perhaps there's a chance that mine has yet to be updated?

    Again, appreciate the wonderful support!
  • Marco_BoeckMarco_Boeck Team Lead Software Engineering Moderator, Employee, Member, University Professor Posts: 1,750   RM Engineering
    Hi,

    can you confirm that you license key starts with "H4sIA" and ends with "5KpEwMAAA=="? I have manually checked your license after the fix went live and it was working - I have just checked again and it is an Academia license capable of connecting to RapidMiner Server.
    Can you please close Studio, go to your USER_HOME/.RapidMiner folder, rename the "licenses" folder to "licenses2" and start Studio again?

    Regards,
    Marco
  • aruberutouaruberutou Member Posts: 23 Contributor I
    Hi, Marco,

    Apologies for the delayed in responding. I can confirm that this final solution here is what fixed it for me.

    Thank you so very much.

  • Marco_BoeckMarco_Boeck Team Lead Software Engineering Moderator, Employee, Member, University Professor Posts: 1,750   RM Engineering
    Hi,

    great to hear! Sorry for the confusion, I was pretty sure your old license would be replaced with the new version. Seems to not be the case. In any case, you can now delete the "license2" folder as Studio does download all your licenses on startup and stores them in the "license" folder anyway.

    Regards,
    Marco
Sign In or Register to comment.