🥳 RAPIDMINER 9.9 IS OUT!!! 🥳

The updates in 9.9 power advanced use cases and offer productivity enhancements for users who prefer to code.

CLICK HERE TO DOWNLOAD

[SOLVED] An attribute dissapears when I use generate id operator

bzavalabzavala Member Posts: 19 Contributor I
edited November 2018 in Help
Hi there, I have a stupid problem when using generate ID operator. I have a data set with a certain number of attributes. The first thing I do is to sort this using the "Material" attribute. Next, I generate an ID for each row. When I do this and look at the results, the column "Material" dissapears. I have looked for a solving for this problem but I found nothing. Also I cant understand why that happens. The only idea that cames to my mind and actually worked out was to duplicate the attribute Material by generating attribute operator,but I think this is an ugly and not professional solution.
Please dont give me lines of code to solve this problem since Im very new using rapidminer and the only thing I know is to work with processes.

Thanks you very much for your help.

PD: sorry if I made a lot of mistakes, I dont speak english  :-\

Answers

  • Marco_BoeckMarco_Boeck Team Lead Software Engineering Administrator, Moderator, Employee, Member, University Professor Posts: 1,958   RM Engineering
    Hi,

    that operator does not change your data. It adds a new id column, but that's it. Are you sure that it's not simply an issue of the id column pushing your Material attribute to the right and thus 'hiding' it behind a horizontal scrollbar?
    If that is not the case, can you please a) post a screenshot of the results where you are missing your attribute and b) the process xml (you can access that by clicking "View -> "Show View" -> "XML").

    Regards,
    Marco
  • bzavalabzavala Member Posts: 19 Contributor I
    Im very sure that the attributte is not hidden. I know that generate id operator only do that, thats  why i dont understand why an attribute dissapears. Here is the screenshot with the output:


    https://www.dropbox.com/s/rhyv0sjra5q5r8u/Captura%20de%20pantalla%202015-09-23%2010.16.57.png?dl=0


    So what I did was generate Material2 before applying generate id operator, so when Material dissapears, it doesn't affect me.  By the way, generate ID appears with red color but it works okay anyway. I have a huge lines of code and many subprocesess, so I coudnt insert it here because exceed the lenght and I coundt find out how to insert an scrolling window with the code on it,
    Thanks you again.
  • Marco_BoeckMarco_Boeck Team Lead Software Engineering Administrator, Moderator, Employee, Member, University Professor Posts: 1,958   RM Engineering
    Hi,

    there is one instance where an attribute will be overridden with "Generate ID": If you already have an attribute with the "id" role. It might be that your Material attribute is considered an id attribute.

    Regards,
    Marco
  • bzavalabzavala Member Posts: 19 Contributor I
    YESS!!! Material was set as ID!!! Thanks you very much!!!! I coudn´t sleep thinking why that happened! Thanks you again  ;D ;D ;D ;D ;D ;D ;D ;D
Sign In or Register to comment.