The Altair Community is migrating to a new platform to provide a better experience for you. The RapidMiner Community will merge with the Altair Community at the same time. In preparation for the migration, both communities are on read-only mode from July 15th - July 24th, 2024. Technical support via cases will continue to work as is. For any urgent requests from Students/Faculty members, please submit the form linked here.

[SOLVED] Cant join two tables

bzavalabzavala Member Posts: 19 Contributor II
edited November 2018 in Help
Hi! I want to make a join between two tables, but the result looks like there's any value in common in the key attribute.  I already checked that key attributes were of the same type (polynomial) and both are attributes. I dont know what else may be the problem. Thanks in advance.

This is my code:

<?xml version="1.0" encoding="UTF-8" standalone="no"?>
<process version="6.4.000">
 <operator activated="true" class="process" compatibility="6.4.000" expanded="true" name="Process">
   <process expanded="true">
     <operator activated="true" class="read_csv" compatibility="6.4.000" expanded="true" height="60" name="Read CSV (5)" width="90" x="45" y="75">
       <parameter key="csv_file" value="C:\Users\BI\Desktop\Beatriz\Cuantificacion quiebres\local 2029\Datos 2\2016.csv"/>
       <parameter key="column_separators" value=","/>
       <parameter key="first_row_as_names" value="false"/>
       <list key="annotations">
         <parameter key="0" value="Name"/>


  • Options
    JEdwardJEdward RapidMiner Certified Analyst, RapidMiner Certified Expert, Member Posts: 578 Unicorn
    For some reason the code seems to be chopped off on my end so I cant see the full process. 

    However, are you definitely sure there are common matches between the attributes? 

    There might be little things that make a difference between the examplesets for instance:
    Set 1Set 2
    In the cases above the word "hello" doesn't match with either of the polynominal values in Set 2. 
    • First because "Hello" contains a capital so isn't an exact match, use a Generate Attributes operator first with "lower(attName)"
    • Second because "hello " contains a sneaky trailing space which again means it's not an exact match, use a Trim operator to fix this.
    Does your data contain anything like this which would mean there are no matches? 
  • Options
    bzavalabzavala Member Posts: 19 Contributor II
    I applied trim operator to my tables and it worked!!! thanks you very much!!
Sign In or Register to comment.