Workspace Lock-Ups

IngoRMIngoRM Administrator, Moderator, Employee, RapidMiner Certified Analyst, RapidMiner Certified Expert, Community Manager, RMResearcher, Member, University Professor Posts: 1,643  RM Founder
edited November 2018 in Help
Original message from SourceForge forum at http://sourceforge.net/forum/forum.php?thread_id=2043208&;forum_id=390413

I've noticed a problem with my Windows XP configuration that locks-up Rapid Miner. Specifically, when I installed Rapid Miner it created the "sample" directory in two separate locations, i.e. 

C:\Program Files\Rapid-I\RapidMiner-4.1\sample 
C:\Documents and Settings\Darrell.OPUS1\My Documents\rm_workspace\sample

However, when I select "Switch Workspace" from the File Menu, Rapid Miner will continually keep adding the workspace to the sample directory until the program locks up. The resulting workspace looks something like this...

C:\Program Files\Rapid-I\RapidMiner-4.1\sample\workspace\sample\workspace\sample\workspace\sample\workspace\sample\workspace\sample... 

Once the directory structure gets too large its very difficult to delete because of file access errors, i.e. the "file name is too long," which may also cause windows to crash. Not sure if anyone else has experienced this problem using "Switch Workspace"...

regards, Darrell


Answer by ****:

Hello Darrell,

thanks for pointing that out. We will have a look into this and I will write back after this issue has been clarified.

Cheers,
Ingo
Sign In or Register to comment.