The Altair Community is migrating to a new platform to provide a better experience for you. The RapidMiner Community will merge with the Altair Community at the same time. In preparation for the migration, both communities are on read-only mode from July 15th - July 24th, 2024. Technical support via cases will continue to work as is. For any urgent requests from Students/Faculty members, please submit the form linked here.

When loading textfiles rapid miner is introducing spaces and special chars

lavramulavramu Member Posts: 16 Contributor II
edited November 2018 in Help

I am trying to do a very simple task of loading text files using the operator "Process documents from files" . After loading I see that there are spaces between each character in the file and also a special character (ÿþ) in the beginning of every file .

example :

b a l a n c e  s h e e t

I am really stuck and would appreciate any help.
I chose the regular options while loading files adn dint see this problem in any of the tutorials and is happening to me


  • Options
    lavramulavramu Member Posts: 16 Contributor II
    adding to my question -- I notice this does not happen to all files but only to the ones I exported from nvivo. But I exported as normal text files and look normal to me but turn up wierd in Rapidminer. Please help.
  • Options
    aborgaborg Member Posts: 66 Contributor II
    Are you sure those second characters are spaces and not with code 0? (Spaces have code 32.) It seems -assuming those are 0s- that the nvivo files are saved as UTF-16 with byte order mark set. (I guess RM do not try to use the encoding specified by BOMs.)
    Cheers, gabor
  • Options
    lavramulavramu Member Posts: 16 Contributor II
    thanks a lot for the reply. They look like spaces to me . I am not sure if they are anything else. In notepad I see them as a white space.
  • Options
    MariusHelfMariusHelf RapidMiner Certified Expert, Member Posts: 1,869 Unicorn
    Di you try to change the encoding parameter of Process Documents from Files?

    Best regards,
  • Options
    lavramulavramu Member Posts: 16 Contributor II
    Let me try and post back..thanks!
Sign In or Register to comment.