"[SOLVED] Overriding macro values"

devzingdevzing Member Posts: 5 Contributor II
edited June 2019 in Help
I'm trying to parameterize my process by using macros. However, I can't seem to change the values.

I've created services with parameters, I've used RM to schedule a process on RA and supplied the macro names and values on the context tab, but the defaults are always used.

Looking at the log it appears that the macros are being supplied twice, default first.
INFO: Process context is: Macros: [k_param : 5, maxdoc : 200, _ra_user : admin, _ra_jobID : 320, k_param : 20, maxdox : 5000]; Input: []; Output: []

How can I make this work?


  • Options
    MariusHelfMariusHelf RapidMiner Certified Expert, Member Posts: 1,869 Unicorn
    It is true that the macros are displayed twice in the logs, but the process should use the manually set ones. You can use e.g. the Print to Console operator to explicitly write the macro values used in the process to the console or log file.

    If this does not work, please make sure that you are using the latest version of the RapidMiner Studio or Server (either 5.3.15/1.3.15 or 6.0/2.0). If you continue to have problems, please let us know.

    Best regards,
  • Options
    devzingdevzing Member Posts: 5 Contributor II
    Thanks for the response.

    I ended up playing with "Generate Data by Users Specification" and putting macros in the attribute values. I was able to prove to myself that everything was working as expected. I then determined that my cron script which was calling the RM process via curl was where the problem was at. I needed to enclose the url in quotes otherwise the "&" symbol was being interpreted by the shell.
Sign In or Register to comment.