The Altair Community is migrating to a new platform to provide a better experience for you. The RapidMiner Community will merge with the Altair Community at the same time. In preparation for the migration, both communities are on read-only mode from July 15th - July 24th, 2024. Technical support via cases will continue to work as is. For any urgent requests from Students/Faculty members, please submit the form linked here.
Options

Recommender Extension: Operator Apply Model

a_isabel_marquea_isabel_marque Member Posts: 3 Contributor I
edited June 2019 in Help
Hi,

I am using the RapidMiner version 5.3.013 with the Recommender Extension version 5.1.1
I'm trying to make some recommendations, so I followed some tutorials I found online.

To import the data to the process I used the operator Read Database. In the table, the attributes are defined as follows: user_id int(11) and item_id bigint(20).

In RapidMiner, after reading the data, the type of both is integer.
Then I used operators Set Role, User k-NN and Apply Model (Item Recommendation) like the tutorials exemplify.

My problem is that, after I run the process, the item_id that appears on results is different from that one that are in the database.
For example, the item_id in the database is 9876543210000 , but in the results of the process the item_id that appears is 2147483647 .
Anyone know why this happens? Did Apply Model (Item Recommendation) deals with bigint attributes?

Thanks for the time and help.
Tagged:

Answers

  • Options
    MariusHelfMariusHelf RapidMiner Certified Expert, Member Posts: 1,869 Unicorn
    The integer type in RapidMiner does not support values above 2147483647. You should try to define the columns in RapidMiner as double. That should solve your problem.

    Best regards,
    Marius
Sign In or Register to comment.