Using python scripting extension with RM Server

sCapatinasCapatina Member Posts: 17 Contributor I
edited November 2018 in Help
Good day,

RM server is telling me: com.rapidminer.operator.UserError: Failed to detect Python at the given path.

I am wondering where can I specify the path to python.exe for RapidMiner server?

Best,

Sebastian

Best Answer

  • Pavithra_RaoPavithra_Rao Posts: 79  RM Data Scientist
    Solution Accepted

    Just to follow up here;

     

    This issue can be solved by adding the python executable path to container.properties files for the desired Job agent.

    The folder path for the container.properties for given Job agent and the property to be added is as highlighted below.

     

    ** Note that you might have to escape the '\' in the path ***

     

    Cheers,

     

    cointainer_properties.png

Answers

  • David_ADavid_A Moderator, Employee, RMResearcher, Member Posts: 177  RM Research
    Hi Sebastian,

    the path has to be specified under Administration > System Setting in the server menu.
    Take a look at the guide for a detailed example (just replace R with python:
    http://docs.rapidminer.com/server/administration/installing-extensions.html

    Best,
    David
  • sCapatinasCapatina Member Posts: 17 Contributor I
    Fantastic, thank you!
  • asureshkumaranasureshkumaran Member Posts: 2 Contributor I

    Administration -- System Settings 

     

    Add the following property

    Linux :

         Property:   rapidminer.python.path       Value:  Python Path

    Windows

         Property:   rapidminer.python_scripting.path       Value:  Python Path

     

  • jsmithjsmith Member Posts: 3 Contributor I

    Hello

     

    I'm having trouble getting RM Server to run a process with a Python script.

     

    I have the Python extension installed in the regular extension folder and the job agent extension folder. The version of the extension is the same in Studio and RM Server (7.4). Under RM Server System Settings, I have the rapidminer.python_scripting.path property set to the correct path for python.exe - this is the same exact path I'm using in Studio, as I have Studio and RM Server on the same machine. The Python path works, as I am able to execute processes in Studio using the Python operator. Everything works fine in Studio, it's when I run the process on RM Server where I get an error: "Python not found. Failed to detect Python at given path. <html>Please adjust the Python path in the Preferences.<br>(Tools -> Preferences -> Python Scripting)</html>" But this path in preferences in Studio works when I run the process in Studio...

     

    Could this be related to Job Agents? I'm not familiar with how they run. Is there a config file in job agents (or sub dirs) where I need to manually add the path? I've set up RM Server with Python and R before on other machines and had no issues, but that was before the Job Agents function...  are they related? Is the Studio Python preference setting not passing to RM Server or getting over-written when the "agent-bundled" Job Agent starts???

     

    I'm using Studio version 8 and RM Server version 8 on Windows 10.

     

    I can run any other process fine on RM Server - everything is working fine, unless I try to run Python.  :/

     

    Any help would be vastly appreciated!

     

    Thanks!

     

    Jason

  • jsmithjsmith Member Posts: 3 Contributor I

    I just wanted to post a followup, as I found a solution:

     

    i entered the rapidminer.python_scripting.path=[path to .exe] in a config file and saved it as ".Rapidminer" in the following location: C:\...\.RapidMinerServer\job-agent\config\container\.RapidMiner

     

    It now works fine. It appears the new job agent in v8 does make a difference, at least in my setup.

    sgenzerEdin_Klapic
  • Pavithra_RaoPavithra_Rao Moderator, Employee, RapidMiner Certified Analyst, RapidMiner Certified Expert, Member Posts: 79  RM Data Scientist

    @jsmith Did you restart the server to get this working? Also, could you please share the config file you have added in location: C:\...\.RapidMinerServer\job-agent\config\container\.RapidMiner

     

    Thanks,

  • yyss1yyss1 Member Posts: 1 Newbie
    hello
    ı have same problem but ı dont know how can ı open to system settings may you help me,please ?

Sign In or Register to comment.