The Altair Community is migrating to a new platform to provide a better experience for you. The RapidMiner Community will merge with the Altair Community at the same time. In preparation for the migration, both communities are on read-only mode from July 15th - July 24th, 2024. Technical support via cases will continue to work as is. For any urgent requests from Students/Faculty members, please submit the form linked here.
Options

Java 8

JEdwardJEdward RapidMiner Certified Analyst, RapidMiner Certified Expert, Member Posts: 578 Unicorn
edited November 2018 in Help
Hi guys,

Is RapidMiner Server now compatible with Java 8 & not only Java 7 now? 
Tagged:

Answers

  • Options
    MartinLiebigMartinLiebig Administrator, Moderator, Employee, RapidMiner Certified Analyst, RapidMiner Certified Expert, University Professor Posts: 3,525 RM Data Scientist
    RapidMiner Version 7.0 only works with Java7
    - Sr. Director Data Solutions, Altair RapidMiner -
    Dortmund, Germany
  • Options
    JEdwardJEdward RapidMiner Certified Analyst, RapidMiner Certified Expert, Member Posts: 578 Unicorn
    But as Oracle only publically release security updates for Java 8 isn't that a worry?  Particularly as RapidMiner Server is installed on web servers? 
    http://www.oracle.com/technetwork/java/javase/documentation/eol-135779.html#Java6-end-public-updates

    I was just reading this article and thought I'd better ensure everything was updated. http://www.theregister.co.uk/2016/03/24/java_flaw_cve_2016_0636/
  • Options
    Marco_BoeckMarco_Boeck Administrator, Moderator, Employee, Member, University Professor Posts: 1,996 RM Engineering
    Hi,

    Java 8 support for RM Server is coming soon™ ;)
    Apart from that, those vulnerabilities don't affect Server because it only affects systems that run untrusted code - i.e. when you have Java in your browser (and you shouldn't anymore).

    Cheers,
    Marco
Sign In or Register to comment.