Options

[SOLVED]user-knn - Can't set attribute to role user identification

ChikoChiko Member Posts: 26 Maven
edited November 2018 in Help
Hi,

I am building a recommender stream in rapid miner studio community version 7.0 and have come across a problem. The user-knn operator expects the example set to have an attribute with role "user identification" and another one with role "item identification". I have inserted the Set Role operator just before the user-Knn, however my target role drop down list for the Set Role operator does not have user/item identification roles. It only has {regular, id, lable, prediction, cluster, weight,batch}. I have rapid miner studio community edition 7.0 and recommenders extension 5.1.1.



How can I get round this?

Regards,

Walter

Answers

  • Options
    MartinLiebigMartinLiebig Administrator, Moderator, Employee, RapidMiner Certified Analyst, RapidMiner Certified Expert, University Professor Posts: 3,509 RM Data Scientist
    Hi,

    you can simply type the name in. this way you can define user specified roles :)

    ~Martin
    - Sr. Director Data Solutions, Altair RapidMiner -
    Dortmund, Germany
  • Options
    ashreimashreim Member Posts: 3 Contributor I
    can't do that in RM 10
Sign In or Register to comment.