text mining process works on desktop but not server

lel5287lel5287 Member Posts: 4 Contributor I
edited June 2019 in Help
I have a text mining process started that I've been able to use with no problems when I run it on my desktop, but when I tried moving it over to the server so it could better accommodate more data later, it breaks down at the text processing step.  Here is the process I was using:
 <?xml version="1.0" encoding="UTF-8" standalone="no"?>
<process version="5.3.015">
  <operator activated="true" class="process" compatibility="5.3.015" expanded="true" name="Process">
    <process expanded="true">
      <operator activated="true" class="retrieve" compatibility="5.3.015" expanded="true" height="60" name="Retrieve CCC Sample 2" width="90" x="45" y="30">
        <parameter key="repository_entry" value="CCC Sample 3"/>
      <operator activated="true" class="generate_attributes" compatibility="5.3.015" expanded="true" height="76" name="Generate Attributes" width="90" x="179" y="30">
        <list key="function_descriptions">
          <parameter key="COMPL2" value="upper(COMPL)"/>
      <operator activated="true" class="select_attributes" compatibility="5.3.015" expanded="true" height="76" name="Select Attributes" width="90" x="313" y="30">
        <parameter key="attribute_filter_type" value="single"/>
        <parameter key="attribute" value="COMPL2"/>
      <operator activated="true" class="nominal_to_text" compatibility="5.3.015" expanded="true" height="76" name="Nominal to Text" width="90" x="447" y="30"/>
      <operator activated="true" class="filter_examples" compatibility="5.3.015" expanded="true" height="76" name="Filter Examples" width="90" x="581" y="30">
        <parameter key="condition_class" value="no_missing_attributes"/>
      <operator activated="true" class="text:process_document_from_data" compatibility="5.3.002" expanded="true" height="76" name="Process Documents from Data" width="90" x="715" y="30">
        <parameter key="keep_text" value="true"/>
        <list key="specify_weights"/>
        <process expanded="true">
          <operator activated="true" class="text:tokenize" compatibility="5.3.002" expanded="true" height="60" name="Tokenize" width="90" x="112" y="75"/>
          <connect from_port="document" to_op="Tokenize" to_port="document"/>
          <connect from_op="Tokenize" from_port="document" to_port="document 1"/>
          <portSpacing port="source_document" spacing="0"/>
          <portSpacing port="sink_document 1" spacing="0"/>
          <portSpacing port="sink_document 2" spacing="0"/>
      <connect from_op="Retrieve CCC Sample 2" from_port="output" to_op="Generate Attributes" to_port="example set input"/>
      <connect from_op="Generate Attributes" from_port="example set output" to_op="Select Attributes" to_port="example set input"/>
      <connect from_op="Select Attributes" from_port="example set output" to_op="Nominal to Text" to_port="example set input"/>
      <connect from_op="Nominal to Text" from_port="example set output" to_op="Filter Examples" to_port="example set input"/>
      <connect from_op="Filter Examples" from_port="example set output" to_op="Process Documents from Data" to_port="example set"/>
      <connect from_op="Process Documents from Data" from_port="example set" to_port="result 1"/>
      <connect from_op="Process Documents from Data" from_port="word list" to_port="result 2"/>
      <portSpacing port="source_input 1" spacing="0"/>
      <portSpacing port="sink_result 1" spacing="0"/>
      <portSpacing port="sink_result 2" spacing="0"/>
      <portSpacing port="sink_result 3" spacing="0"/>
When I try to run it on the server, though, I get the following error message:
SEVERE: Process failed: com.rapidminer.operator.UserError: The dummy operator Process Documents from Data (replacing text:process_document_from_data) cannot be executed.
com.rapidminer.operator.UserError: The dummy operator Process Documents from Data (replacing text:process_document_from_data) cannot be executed.

Any thoughts as to how I can fix this?



  • Options
    awchisholmawchisholm RapidMiner Certified Expert, Member Posts: 458 Unicorn
    Is the text mining extension installed on the server?


  • Options
    lel5287lel5287 Member Posts: 4 Contributor I
    I did not realize that I needed to do that.

    I tried following the directions here: https://rapid-i.com/rapidforum/index.php?topic=3127.0, but I had trouble finding the actual .jar file referenced in the post.  The sourceforge linkdoesn't have any files available anymore, and I couldn't figure out which of the jar files in my program files would be the text processing operator. (It probably doesn't help that the instructions are 5 years old.)

    I saw that there was a download available on the marketplace website, but it requires version 7.0+, and I'm still on 5.3.
Sign In or Register to comment.