Options

Message: Cannot parse document: Content is not allowed in prolog.

sCapatinasCapatina Member Posts: 17 Contributor II
edited November 2018 in Help
Hello,

My pc crashed as I was working on a process. Now when i try to open it, I get this error:

Exception: com.rapidminer.tools.XMLException
Message: Cannot parse document: Content is not allowed in prolog.
Stack trace:

  com.rapidminer.Process.readProcess(Process.java:1239)
  com.rapidminer.Process.readProcess(Process.java:1214)
  com.rapidminer.Process.<init>(Process.java:288)
  com.rapidminer.RepositoryProcessLocation.load(RepositoryProcessLocation.java:106)
  com.rapidminer.gui.actions.OpenAction$2.run(OpenAction.java:136)
  com.rapidminer.gui.tools.ProgressThread$3.run(ProgressThread.java:550)
  java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1142)
  java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:617)
  java.lang.Thread.run(Thread.java:745)

Cause
Exception: org.xml.sax.SAXParseException
Message: Content is not allowed in prolog.
Stack trace:

  com.sun.org.apache.xerces.internal.parsers.DOMParser.parse(DOMParser.java:257)
  com.sun.org.apache.xerces.internal.jaxp.DocumentBuilderImpl.parse(DocumentBuilderImpl.java:348)
  com.rapidminer.Process.readProcess(Process.java:1226)
  com.rapidminer.Process.readProcess(Process.java:1214)
  com.rapidminer.Process.<init>(Process.java:288)
  com.rapidminer.RepositoryProcessLocation.load(RepositoryProcessLocation.java:106)
  com.rapidminer.gui.actions.OpenAction$2.run(OpenAction.java:136)
  com.rapidminer.gui.tools.ProgressThread$3.run(ProgressThread.java:550)
  java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1142)
  java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:617)
  java.lang.Thread.run(Thread.java:745)


When I open the .rmp file, this is all I see:
0000 0000 0000 0000 0000 0000 0000 0000
0000 0000 0000 0000 0000 0000 0000 0000
0000 0000 0000 0000 0000 0000 0000 0000
0000 0000 0000 0000 0000 0000 0000 0000
0000 0000 0000 0000 0000 0000 0000 0000
0000 0000 0000 0000 0000 0000 0000 0000
0000 0000 0000 0000 0000 0000 0000 0000
0000 0000 0000 0000 0000 0000 0000 0000
0000 0000 0000 0000 0000 0000 0000 0000
0000 0000 0000 0000 0000 0000 0000 0000
0000 0000 0000 0000 0000 0000 0000 0000
0000 0000 0000 0000 0000 0000 0000 0000
0000 0000 0000 0000 0000 0000 0000 0000
0000 0000 0000 0000 0000 0000 0000 0000
0000 0000 0000 0000 0000 0000 0000 0000
0000 0000 0000 0000 0000 0000 0000 0000
0000 0000 0000 0000 0000 0000 0000 0000
0000 0000 0000 0000 0000 0000 0000 0000
0000 0000 0000 0000 0000 0000 0000 0000
0000 0000 0000 0000 0000 0000 0000 0000
0000 0000 0000 0000 0000 0000 0000 0000
0000 0000 0000 0000 0000 0000 0000 0000
0000 0000 0000 0000 0000 0000 0000 0000
0000 0000 0000 0000 0000 0000 0000 0000
0000 0000 0000 0000 0000 0000 0000 0000
0000 0000 0000 0000 0000 0000 0000 0000
0000 0000 0000 0000 0000 0000 0000 0000
0000 0000 0000 0000 0000 0000 0000 0000
0000 0000 0000 0000 0000 0000 0000 0000
0000 0000 0000 0000 0000 0000 0000 0000
0000 0000 0000 0000 0000 0000 0000 0000
0000 0000 0000 0000 0000 0000 0000 0000
0000 0000 0000 0000 0000 0000 0000 0000
0000 0000 0000 0000 0000 0000 0000 0000
0000 0000 0000 0000 0000 0000 0000 0000
0000 0000 0000 0000 0000 0000 0000 0000
0000 0000 0000 0000 0000 0000 0000 0000
0000 0000 0000 0000 0000 0000 0000 0000
0000 0000 0000 0000 0000 0000 0000 0000
0000 0000 0000 0000 0000 0000 0000 0000
0000 0000 0000 0000 0000 0000 0000 0000
0000 0000 0000 0000 0000 0000 0000 0000
0000 0000 0000 0000 0000 0000 0000 0000
0000 0000 0000 0000 0000 0000 0000 0000
0000 0000 0000 0000 0000 0000 0000 0000
0000 0000 0000 0000 0000 0000 0000 0000


I have a feeling I just lost countless hours of work ...

Answers

  • Options
    MartinLiebigMartinLiebig Administrator, Moderator, Employee, RapidMiner Certified Analyst, RapidMiner Certified Expert, University Professor Posts: 3,517 RM Data Scientist
    This might be because it's rmp and not xml?

    Try read it with File->Import Process
    - Sr. Director Data Solutions, Altair RapidMiner -
    Dortmund, Germany
  • Options
    Marco_BoeckMarco_Boeck Administrator, Moderator, Employee, Member, University Professor Posts: 1,996 RM Engineering
    Hi,

    When Studio crashes, the next time you start it will prompt that an unsaved process was found. This can be used to restore the last working state:

    image

    Can be manually looked up in USER_HOME/.RapidMiner/autosave/ folder.

    If a .rmp file contains only 0s, then it is corrupted. The .rmp file in reality is nothing else than a simple text file containing XML.

    Hope this helps you :-[
    Marco
  • Options
    sCapatinasCapatina Member Posts: 17 Contributor II
    Thanks for the suggestions. It seems my process corrupted. I am sure its linked to the windows insider build I am using

    Windows has a file history feature, which I will be using going forward to autosave versions of my rmp files

    Well, at least the process will be better building it the second time round :)
  • Options
    s10176108s10176108 Member Posts: 3 Contributor I

    Hi

     

    I had the same error message when i was trying to import processes (importing it from excel). I can import the same data set from school lab but not at home. Can I add data instead? 

     

    Im still new to rapidminer

     

    thanks

  • Options
    s10176108s10176108 Member Posts: 3 Contributor I

    hi 

     

    i have just downloaded the rapidminer but i cant import csv file because i do not have such function. Refer to the attachment.

     

    Any solution for that?

     

    Thanks.

Sign In or Register to comment.