Options

"The maximum memory setting of X is not valid for your current license"

RondogRondog Member Posts: 2 Contributor I
edited June 2019 in Help
Hi,

having installed studio i keep getting the error "The maximum memory setting of "7.282" MB is not valid for your current license. Please make sure that the RapidMiner Studio launch script is not manipulated and restart Rapidminer Studio". When I click OK it stops launch.

This happens if I try to launch from rapid miner.jar.

If I try launching from the main RapidMiner Studio icon I get the warning "Starting RapidMiner Studio failed! Reason: RapidMiner Studio requires Java 1.7 or newer. Found Java 1.6."
I have Mavericks, latest version of Java and XQuartz installed.

What do I need to do to get past this?

Thanks,

Jon

Tagged:

Answers

  • Options
    MichaelKnopfMichaelKnopf Administrator, Employee, RapidMiner Certified Analyst, RapidMiner Certified Expert, Member Posts: 31 RM Data Scientist
    Hi Jon,

    When starting RapidMiner Studio manually using the JAR file, the Java Virtual Machine allocates as much memory as it likes (in your case about 7GB). To prevent this, you have to specify an upper limit. For instance, launching the JAR via "java -Xmx1024M -jar rapidminer.jar" will ensure that only 1GB of memory is used. You can adopt "1024M" to whatever your license supports.

    However, this should be done automatically by the RapidMiner Studio launcher. Unfortunately, the launcher fails to detect the correct Java installation on your machine. I just created a new sticky post adressing this issue:

    http://rapid-i.com/rapidforum/index.php/topic,7627.0.html

    Cheers,
    Michael
  • Options
    RondogRondog Member Posts: 2 Contributor I
    Thanks Michael,

    The only problem is that I am not sure how to apply the advice of launching via "java -Xmx1024M -jar rapidminer.jar"
    I presume you mean to enter this in Terminal, but when I do this I just get another error message.
    Is this because I have more than one version of RapidMiner on my Mac?

    Cheers,

    Jon
  • Options
    MichaelKnopfMichaelKnopf Administrator, Employee, RapidMiner Certified Analyst, RapidMiner Certified Expert, Member Posts: 31 RM Data Scientist
    Hi Jon,

    sorry I did not elaborate. I assumed you were already launchign the JAR via the Terminal using a similar command (and somehow managed to specify the corrent Java installation). To run the command you have to navigate to the directory containing the JAR file first. I won't elaborate how do to this (again  ;)), since I doubt the command will work for you as it seems that you command line Java point at Apple's Java 6 (1.6) release. Furthermore, even if should work, starting RapidMiner Studio this way may have annoying side effects.

    I strongly recommend to try the preview of the new launcher (the "main RapidMiner Studio icon") as described in the sticky post I linked in my previous reply.

    If this does not work for you please look up the information described in the feedback section in said thread.

    Cheers,
    Michael
  • Options
    andrewdempseyandrewdempsey Member Posts: 1 Contributor I
    I have the same problems.

    I am using the preview launcher as per the referred thread, which starts RM fine, but when selecting the "continue using starter" option on the subsequent popup, I get the maximum memory setting error message. Unfortunately, I do not see a way of changing the java configuration in order to allow me to continue to use the starter version.

    To a certain extent, this bug prevents the evaluation of RM using the starter version on MAC at this time. Or at least evaluations that take longer than the 14 day trial of the professional version... In my experience, software evaluations tend to take more than 14 days unless one of your employees is already familiar with the package.
  • Options
    Marco_BoeckMarco_Boeck Administrator, Moderator, Employee, Member, University Professor Posts: 1,996 RM Engineering
    Hi,

    thanks for the report, we are investigating if the beta launcher fails to setup the memory usage correctly. For the time being, you can launch RapidMiner Studio manually by calling "java -Xmx1024M -jar rapidminer.jar" from the Terminal when inside the Rapidminer Studio/lib folder.

    Edit:

    When did you download the preview launcher? It was updated about a month ago. Also can you please post the content of the OSX-Startup.log (can be found in the same folder as the launcher) and the content of the launcher.log from the user home/.RapidMiner/ folder?

    Regards,
    Marco
  • Options
    ozoz Member Posts: 1 Contributor I
    Hi,
    one more piece of info about this issue..
    Preview Launcher seems to limit the memory to 3641 Mb, During the trial period I was getting the memory error while running large data sets, reporting that I am out of memory  at 3641 Mb although the trial license allows up to 8000 Mb.

    Another question about the manual start workaround:

    In Rapidminer Studio/lib folder there is no rapidminer.jar file.... Am I missing something?
    Thanks
Sign In or Register to comment.