I could not configure R extension! Help please.

DDelenDDelen Member Posts: 12 Contributor II
edited September 2019 in Help
I have been trying to configure R extension for a quite sometime. I still cannot get it working. The guideline is not helping either. Here are the specifics:
1. I installed R version 3.1.0
2. I successfully ran install.packages("rJava")
3. I executed .libPaths() ... here what I get is only one thing:
> .libPaths()
[1] "C:/Program Files/R/R-3.1.0/library"
>
AM I SUPPOSED TTO GET MORE... AT LEAST ONE THAT IS SPECIFIC TO rJava?

4. I created R_HOME; i added the R folder location to PATH environment variable
5. I created JAVA_HOME environment variable
6. I selected "Select JRI library file" selected the proper jre file... manually restarted RapidMiner 6.0.3

I GOT THE SAME ERROR DURING START UP:
R Extension could not be initialized. Error while loading native R library. Please check PATH, R_HOME and JAVA_HOME environment variable settings.
Reason: "C:\Program Files\R/R-3.1.0\library\rJava\jri\x64\jri.dll: Can't find dependent libraries'.

This is frustrating... Please help!

Delen 
Tagged:

Answers

  • BokhaBokha Member Posts: 1 Contributor I
    I am having the same problem on Ubuntu!

    1. Installed R version 2.12.2 configured with shared library libR.so
    2. Successfully installed both rJava and JavaGD which got installed in  /home/shiladitya/R/x86_64-unknown-linux-gnu-library/2.12/
    3. .libPaths() gives
            [1] "/home/shiladitya/R/x86_64-unknown-linux-gnu-library/2.12"
            [2] "/usr/local/lib64/R/library"
    4. Created R_HOME=/usr/local/lib64/R which I got from R.home()
    5. Created JAVA_HOME=/usr/lib/jvm/java-7-openjdk-amd64/jre
    6. My PATH variable contains
                        ...: /usr/local/lib64/R:/usr/local/lib64/R/bin:/usr/lib/jvm/java-7-openjdk-amd64/jre: ....
    7. Got the extension from the Marketplace and selected the jri library file:
                            /home/username/R/x86_64-unknown-linux-gnu-library/2.12/rJava/jri/libjri.so

    And still after restarting R I'm finding a window with this message:

        R extension could not be initialized. Error while loading native R library. Please check PATH, R_HOME and JAVA_HOME environment variable settings.

        Reason: /home/shiladitya/R/x86_64-unknown-linux-gnu-library/2.12/rJava/jri/libjri.so: libR.so: cannot open shared object file: No such file or directory


    I have been trying desperately for nearly 2 days to sort this out and I really need the R extension on RapidMiner for my work...I have searched through all forums without success...please help!

    My RapidMiner version is 5.3.13.
  • srp2006srp2006 Member Posts: 1 Contributor I
    I have been having the same problems as DDELEN (Reason: "C:\Program Files\R/R-3.1.0\library\rJava\jri\x64\jri.dll: Can't find dependent libraries'.), and I suspect it has something to do with rJava. I used a program "Dependency Walker" to identify where the problems were with my jri file, and at first the problem was that r.dll was not in my rJava folder (C:\Program Files\R\R-3.1.0\library\rJava\jri\x64). I then add added r.dll to this folder, but then the Dependency Walker said there were errors related to RBLAS.dll, RGRAPHAPP.dll, etc. That's probably because r.dll was moved to a new location, affecting the default locations for the downstream dll's. I'm not sure how to resolve, but it seems like the rJava locations are not correct, or I'm directing windows to search in the wrong folder.

    I've added my path variables
    (C:\Program Files\R\ R-3.1.0\library;    
    C:\Program Files\R\ R-3.1.0\include;    
    C:\Program Files\Java\jre7\bin\server;    
    C:\Program Files\Java\jre7\bin;    
    C:\Program Files\R\ R-3.1.0\bin\x64;    
    C:\Program Files\R\ R-3.1.0\library\rJava\jri\x64;)

    I've defined R Home (C:\Program Files\R\R-3.1.0\) and JAVA_HOME. I've tried setting JAVA_HOME to either of the following, and neither worked:
    C:\Program Files\RapidMiner\RapidMiner Studio\jre
    C:\Program Files\Java\jre7

    Any suggestions?
  • Marco_BoeckMarco_Boeck Team Lead Software Engineering Administrator, Moderator, Employee, Member, University Professor Posts: 1,905   RM Engineering
    Hi,

    R 3.x does not seem to work with the current R Extension. I could not get it to work myself. I uninstalled it, deleted installation and libPaths folders and then installed R version 2.15.

    Then I followed the instructions of the Extension which resulted in me getting a "Can't find dependent libraries" error on startup.
    I was able to solve this by not only putting "R_INSTALLATION_FOLDER\bin" on the PATH, but also "R_INSTALLATION_FOLDER\bin\x64" (change x64 to i386 if you are on a 32bit machine). Restarting Studio then presented me with a dialog where I had to select a download mirror and it all was smooth sailing from there.

    Hope this helps somebody else!

    Regards,
    Marco
  • MikaMika Member Posts: 3 Contributor I
    My set-up Windows 7, RM 5.3, R 3.1.2 all 64-bit.

    I could not get the R extension running although I followed the set-up quidelines to the point. Finally, after spending hours on it, I got it running. This is what I did on top of the steps given in R extension set-up:
    1. copied rJava folder from "C:/Users/<MyUserName>/Documents/R/win-library/3.1" to "C:/Program Files/R/R-3,1,2/library" This requires administration rights
    2. deleted jri.dll from "C:\Program Files\R\R-3.1.2\library\rJava\jri" This is a 32-bit version
    3. copied jri.dll from "C:\Program Files\R\R-3.1.2\library\rJava\jri\x64" to the folder above This is the 64-bit version

    I cannot tell whether the step 1 is required or not, or would just steps 2 and 3 be sufficient. My R extension is running now and I will not touch it anymore  ;)
Sign In or Register to comment.