Read CSV doesn't work

dajoedicdajoedic Member Posts: 1 Contributor I
edited October 2019 in Help
Hello,

I didn't work for a long time with Rapit Miner and I have a problem with reading csv files.
I use the "Read CSV" operator, select my csv file with the "Import Configuration Wizard", follow the steps and want to do some kind of clustering afterwards. When I run the prozess there is always the Error Message: "No input file was defined. No file input defined: depending on the source type configuration of your operator, you have to either connect the file input port or define the parameters which specifies the file to be read."

Reading Excel files work fine.

I'm using RapidMiner 5.3.013.

For more information please contact me.

Thankls for your help.

David
Tagged:
ggoralT_Anastasia

Answers

  • homburghomburg Moderator, Employee, Member Posts: 114 RM Data Scientist
    Hi dajoedic,

    it looks like there is no file associated to the "Read CSV" operator. Did you use the import wizard directly from the parameter tab of the operator? It would be great if you could post the xml code of your process here.

    Cheers,
       Helge
  • corkiecorkie Member Posts: 10 Contributor II
    with a new process locate the read CSV operator
    add it to the main process window
    wire the op port to res
    click on the wizard
    locate the csv file
    click next
    in the file reading confirm encoding = UTF-8
    in the comma separation note the default = ';'
    you need to set this to ','
    NEXT
    NEXT
    FINISH
    data should be there now.

    if its not the case then as per the previous response you will need to send the XML code for analysis
  • hi_joshihi_joshi Member Posts: 2 Contributor I

    Unfortunately, the steps provided to address this issue are not very helpful. They seem to assume a lot of things. For example, how does anyone who is using RapidMiner for the first time to get a feel of it, know how to generate an XML file for the process? 

     

    Besides, there are several other issues I am noticing right now with the overall UI itself. I am unable to find the "Data" option which I saw right after installation which I could use to play with IRIS data. I have restarted RapidMiner so many times after that and was never to get that option again. 

     

    I read the reviews about RapidMiner and they all seem to be speaking very high of it. I was very hopeful to see a good and intuitive tool when I read those reviews. But I am not really pleased with what I have seen so far. Maybe, it might be something at my end, but looks like a lot needs to be done, especially testing of the tool, at the RapidMiner end as well. 

     

    Hope someone will take notice of this feedback. 

     

    Manoj Joshi

     

  • hi_joshihi_joshi Member Posts: 2 Contributor I

    After some failed attempts, I finally got make it work. I think the tool has a lot of potential and I want to tell the product team that they really seem to have done a good job. However, the UI interface needs to be more intuitive and effective. For a first timer (who could be just a beginner or an experienced data scientist who might be evaluating it for some serious work for his/her organization), the very first experience is not without disappointment even when trying simple things. For example, I wanted to simply try running a decision tree with the IRIS dataset but getting it work really proved to be quite a challenge. I wanted to compare the output of the decision tree predictions of RapidMiner with the model I prepared using Scikit-learn in Python and see how close the two were.

     

    Anyway, now that I made it work, I will continue exploring it more and probably some of the early frustrating experience I had with it will probably be compensated with some cool features it has to offer.

     

    One thing I would add is the You Tube videos they provided are really of big help. I suggest they should add more such videos to help generate the knowledge about the tool. 

     

     

  • ggoralggoral Member Posts: 1 Contributor I

    How did you make it work? I got make it work, removing input conection to read csv operator.

     

    Thx!

  • T_AnastasiaT_Anastasia Member Posts: 3 Contributor I
    You need to import file as data in "repository" menu.
    unless it doesn't work.
    Why it didn't bound file with your config - I dunno.

  • T_AnastasiaT_Anastasia Member Posts: 3 Contributor I
    I mistaked. It still not works for me.
    1st file - just master import then press "play"
    2nd file - import data then press "play"
  • varunm1varunm1 Moderator, Member Posts: 1,207 Unicorn
    Hello @T_Anastasia

    I see that you imported a file into repository based in the second file you attached. Why do you want to use read CSV as the file is already in your repository? You should drag and drop the file from repository to process window directly, no need to read CSV.

    The problem in your earlier process is you connected read CSV to "inp" remove that and you will see an option in read CSV parameters, there you can browse and point to the CSV file in your pc.




    Regards,
    Varun
    https://www.varunmandalapu.com/

    Be Safe. Follow precautions and Maintain Social Distancing

    sgenzer
  • T_AnastasiaT_Anastasia Member Posts: 3 Contributor I
    got it. Thanks

    varunm1
Sign In or Register to comment.