Options

Rapid Miner Studio 6 not Starting

BertrandKisBertrandKis Member Posts: 3 Contributor I
edited April 2020 in Help
Hello to the good people out there,
I have installed Rapid Miner studio 6 no Windows 7 and the installation was perfect.
However when I try to start it from the shortcut icon or the program menu, nothing happens.
I don't know if that is because I am not the administrator on the machine.
Can someone advise if I have to be in the administrator group to be able to use Rapid miner studio.

Regards

Tagged:

Answers

  • Options
    Marco_BoeckMarco_Boeck Administrator, Moderator, Employee, Member, University Professor Posts: 1,993 RM Engineering
    Hi,

    the dreaded "silent fail" on Windows 7.. I'm guessing you're on the 32-bit version then, correct? Most of the time when this happens the problem is that Java (because RapidMiner Studio is written in Java) tries to allocate around 1GB of memory and fails doing so, probably because there is not enough free memory available at startup time. The .exe file then quits and it looks like nothing has happened. This "silent fail" on Windows 32 -bit will finally be fixed with the next patch, though.
    What you can do for now is to make sure you have around 1200MB of main memory available when starting RapidMiner Studio. If that does not help, you can try starting the .bat GUI start script from the commandline which is found in the main folder where you installed RapidMiner Studio. You can then check what kind of error you get as there is always the chance it's a different problem.

    Regards,
    Marco
  • Options
    BertrandKisBertrandKis Member Posts: 3 Contributor I
    Hi Marco, Thank you for prompt response.
    I have tried everything you suggested, but still no Joy.
    I have W7 32 bits, 4GB RAM with 2.4GB available most of the time.
    I have tried to execute the .bat file, the black window just flashes on the screen and disappears.
    What esle can I try?

    Thanks
  • Options
    Marco_BoeckMarco_Boeck Administrator, Moderator, Employee, Member, University Professor Posts: 1,993 RM Engineering
    Hi,

    there is one workaround which you could utilize to actually use RapidMiner Studio before the next patch will be released. You need to start a cmd console (click on the start menu button, enter "cmd" in the search field and press Enter. In the console you now have to start it manually. See below for the command necessary:

    java -cp "C:\Program Files\RapidMiner\RapidMiner Studio\lib\*";"C:\Program Files\RapidMiner\RapidMiner Studio\lib\jdbc\*" com.rapidminer.launcher.GUILauncher
    There is one downside to this approach though: The update mechanism of Studio will not work. You'd have to download and install 6.0.9 (the version which will fix your problem) manually once it will be released some time in the future (I don't have a date yet).

    To actually read the error message you get when starting normally, you'd need to start the .bat file from the cmd console. Otherwise it just vanishes after the error. This will also be fixed with the next patch.

    Sorry for the inconvenience!

    Regards,
    Marco
Sign In or Register to comment.