RapidMiner 5.3 won't run

mbensonmbenson Member Posts: 4 Contributor I
edited November 2018 in Help
Hi, very basic problem here.

I am learning Rapidminer. I downloaded 5.3 and tried some various exercises that worked wonderfully. Rapidminer is fun!

I'm running the Windows version on Win 7. The laptop I am using belongs to my employer, and may have some weird security policies in place, but looking at the logs, I see no evernts related to trying to start Rapidminer. I could however be looking at the wrong place, as there are layers of security going on.

Anyway, Rapidminer used to run fine. I am hoping  to teach some students some very basic data mining and analytics concepts with it, and I can no longer work with it myself.

If I try to run the executable, either from the shortcut or the file, the cursor turns to  "busy" and then nothing happens. This is true when I try running it as administrator as well. There are no error messages.

Does anyone have any ideas?

Thank you very much!


  • mbensonmbenson Member Posts: 4 Contributor I

    Rapidminer runs from the .jar but not from .exe.

    What's up with that? Weird.

    Oh - Java 1.7.0_67
  • homburghomburg Moderator, Employee, Member Posts: 114 RM Data Scientist
    Hi mbenson,

    looks like there is something wrong with your RapidMiner configuration. Could you try to run the RapidMinerGUI.bat from your installation directory (usually something like C:\Program Files\Rapid-I\RapidMiner5\scripts)? If RapidMiner cannot start this way you should see some error messages.

  • mbensonmbenson Member Posts: 4 Contributor I
    Hi, Helge.

    I ran the batch file and saw no major errors appear. Once the .bat has been run, it looks like it establishes environment variables in memory that allow the EXE to run.

    Should their be a permanent environment variable or variables configured in the system to allow the .EXE to run every time from the menu and task bar short cuts, or no?

    Anyway, I know how to get it to run now, so that is good. I'm curious now about what changed on my system between when it used to run from .exe to the current situation.

  • homburghomburg Moderator, Employee, Member Posts: 114 RM Data Scientist
    Hi Martin,

    good to hear that it is working using the script. The exe file does more or less the same than the batch file. The reason that it does not work out of the box might be a version mismatch which caused the exe to stop in a rather less verbose way...
    Have you installed RapidMiner using the 32bit or 64bit version? What java is installed (32 or 64bit)? Maybe those two versions do not fit.

  • mbensonmbenson Member Posts: 4 Contributor I
    I think I am fine now. Thanks for your help and concern. I will be able to do my demonstration tomorrow.
  • vinayarunvinayarun Member Posts: 7 Contributor II

    I am facing this same problem with the latest version 7 of RapidMiner installed on my windows office laptop. When clicked mouse turns busy fore 2 seconds then nothing happens!

    I have tried running the .bat files but same problem. No error message nothing but RapidMiner won't start at all!

    Please help!
Sign In or Register to comment.